From: Parker Newman <pnewman@xxxxxxxxxxxxxxx>
Remove ternary operators from cti_get_port_type_xr17c15x_xr17v25x() for
better readability.
Signed-off-by: Parker Newman <pnewman@xxxxxxxxxxxxxxx>
--- a/drivers/tty/serial/8250/8250_exar.c
+++ b/drivers/tty/serial/8250/8250_exar.c
@@ -726,7 +726,7 @@ static enum cti_port_type cti_get_port_type_xr17c15x_xr17v25x(struct exar8250 *p
struct pci_dev *pcidev,
unsigned int port_num)
{
- enum cti_port_type port_type;
+ enum cti_port_type port_type = CTI_PORT_TYPE_RS232;
switch (pcidev->subsystem_device) {
// RS232 only cards