Re: [PATCH v2 2/5] KVM: x86: Introduce KVM_X86_CALL() to simplify static calls of kvm_x86_ops

From: Sean Christopherson
Date: Mon Apr 22 2024 - 12:45:43 EST


On Mon, Apr 22, 2024, Paolo Bonzini wrote:
> On Fri, Apr 19, 2024 at 1:30 PM Wei Wang <wei.w.wang@xxxxxxxxx> wrote:
> > +#define KVM_X86_CALL(func, ...) static_call(kvm_x86_##func)(__VA_ARGS__)
>
> Just
>
> #define KVM_X86_CALL(func) static_call(kvm_x86_##func)
>
> please, because having the parentheses around the arguments is a lot
> more readable

+1, the more these look like function calls, the better.