Re: [PATCH 1/4] i2c: designware: Create shared header hosting driver name
From: Andy Shevchenko
Date: Tue Apr 23 2024 - 19:59:31 EST
Tue, Apr 23, 2024 at 04:36:19PM -0700, Florian Fainelli kirjoitti:
> We have a number of drivers that reference the string "i2c_designware"
> yet this is copied all over the places with opportunities for this
> string being mis-used. Create a shared header that defines this as a
> constant that other drivers can reference.
..
> #include <linux/i2c.h>
> +#include <linux/i2c-designware.h>
Can it be hidden in the subfolder?
..
> -#define DRIVER_NAME "i2c-designware-pci"
> +#define DRIVER_NAME I2C_DESIGNWARE_NAME "-pci"
Oh, this makes all the things hard to read.
> /* Work with hotplug and coldplug */
> -MODULE_ALIAS("i2c_designware-pci");
> +MODULE_ALIAS(DRIVER_NAME);
I believe we shouldn't use MODULE_ALIAS() without real justification.
..
> --- a/drivers/i2c/busses/i2c-designware-platdrv.c
> +++ b/drivers/i2c/busses/i2c-designware-platdrv.c
All as per above.
--
With Best Regards,
Andy Shevchenko