[PATCH RFC md-6.10 0/9] md: refactor and cleanup for sync action
From: Yu Kuai
Date: Wed May 08 2024 - 21:29:23 EST
From: Yu Kuai <yukuai3@xxxxxxxxxx>
Motivation of this patchset is that during code review, I found some
places is not good coded, and I decide to make code more readable.
Yu Kuai (9):
md: rearrange recovery_flage
md: add a new enum type sync_action
md: add new helpers for sync_action
md: factor out helper to start reshape from action_store()
md: replace sysfs api sync_action with new helpers
md: use new helers in md_do_sync()
md: replace last_sync_action with new enum type
md: factor out helpers for different sync_action in md_do_sync()
md: pass in max_sectors for pers->sync_request()
drivers/md/dm-raid.c | 2 +-
drivers/md/md.c | 367 ++++++++++++++++++++++++++++---------------
drivers/md/md.h | 122 +++++++++++---
drivers/md/raid1.c | 5 +-
drivers/md/raid10.c | 8 +-
drivers/md/raid5.c | 3 +-
6 files changed, 344 insertions(+), 163 deletions(-)
--
2.39.2