Re: [PATCH net v4] nfc: nci: Fix uninit-value in nci_rx_work

From: Ryosuke Yasuoka
Date: Sat May 11 2024 - 07:02:49 EST


Thank you for your review.

On Fri, May 10, 2024 at 07:06:13PM -0700, Jakub Kicinski wrote:
> On Thu, 9 May 2024 20:30:33 +0900 Ryosuke Yasuoka wrote:
> > - if (!nci_plen(skb->data)) {
> > + if (!skb->len) {
> > kfree_skb(skb);
> > - kcov_remote_stop();
> > - break;
> > + continue;
>
> the change from break to continue looks unrelated

OK. I'll leave this break in this patch. I'll send another patch about
it.

> > }
>
> > - nci_ntf_packet(ndev, skb);
> > + if (nci_valid_size(skb, NCI_CTRL_HDR_SIZE))
>
> > + if (nci_valid_size(skb, NCI_DATA_HDR_SIZE))
>
>
> #define NCI_CTRL_HDR_SIZE 3
> #define NCI_DATA_HDR_SIZE 3
>
> you can add a BUILD_BUG_ON(NCI_CTRL_HDR_SIZE == NCI_DATA_HDR_SIZE)
> and save all the code duplication.
>

Sorry I don't get it. Do you mean I just insert
BUILD_BUG_ON(NCI_CTRL_HDR_SIZE != NCI_DATA_HDR_SIZE) or insert this and
clean up the code duplication like this? (It is just a draft. I just
share what I mean.) I can avoid to call nci_valid_size() repeatedly
inside the switch statement.

static void nci_rx_work(struct work_struct *work)
{
..
if (!skb->len) {
kfree_skb(skb);
kcov_remote_stop();
break;
}

BUILD_BUG_ON(NCI_CTRL_HDR_SIZE != NCI_DATA_HDR_SIZE);
unsigned int hdr_size = NCI_CTRL_HDR_SIZE;

if (!nci_valid_size(skb, hdr_size)) {
kfree_skb(skb);
continue;
}

/* Process frame */
switch (nci_mt(skb->data)) {
case NCI_MT_RSP_PKT:
nci_rsp_packet(ndev, skb);
break;

case NCI_MT_NTF_PKT:
nci_ntf_packet(ndev, skb);
break;