[PATCH 0/3] Rework mce_setup()

From: Yazen Ghannam
Date: Tue May 21 2024 - 08:54:59 EST


Hi all,

This set is the next revision of the following patches:
https://lkml.kernel.org/r/20240404151359.47970-2-yazen.ghannam@xxxxxxx
https://lkml.kernel.org/r/20240404151359.47970-3-yazen.ghannam@xxxxxxx

Patch 1 does the function renaming that Boris suggested.

Patches 2 and 3 are mostly unchanged except for rebasing on patch 1.

Thanks,
Yazen

Yazen Ghannam (3):
x86/mce: Rename mce_setup() to mce_prep_record()
x86/mce: Define mce_prep_record() helpers for common and per-CPU
fields
x86/mce: Use mce_prep_record() helpers for
apei_smca_report_x86_error()

arch/x86/include/asm/mce.h | 2 +-
arch/x86/kernel/cpu/mce/amd.c | 2 +-
arch/x86/kernel/cpu/mce/apei.c | 19 +++++++--------
arch/x86/kernel/cpu/mce/core.c | 38 ++++++++++++++++++++----------
arch/x86/kernel/cpu/mce/internal.h | 2 ++
5 files changed, 37 insertions(+), 26 deletions(-)


base-commit: 108c6494bdf1dfeaefc0a506e2f471aa92fafdd6
--
2.34.1