[PATCH v3 0/3] Clean up usage of rt_task()

From: Qais Yousef
Date: Mon May 27 2024 - 19:45:28 EST


Make rt_task() return true only for RT class and add new realtime_task() to
return true for RT and DL classes to avoid some confusion the old API can
cause.

No functional changes intended in patch 1. Patch 2 changes hrtimer users as
suggested by Sebastian. Patch 3 cleans up the return type as suggested by
Steve.

Changes since v2:

* Fix one user that should use realtime_task() but remained using
rt_task() (Sebastian)
* New patch to convert all hrtimer users to use realtime_task_policy()
(Sebastian)
* Add a new patch to convert return type to bool (Steve)
* Rebase on tip/sched/core and handle a conflict with code shuffle to
syscalls.c
* Add Reviewed-by Steve

Changes since v1:

* Use realtime_task_policy() instead task_has_realtime_policy() (Peter)
* Improve commit message readability about replace some rt_task()
users.

v1 discussion: https://lore.kernel.org/lkml/20240514234112.792989-1-qyousef@xxxxxxxxxxx/
v2 discussion: https://lore.kernel.org/lkml/20240515220536.823145-1-qyousef@xxxxxxxxxxx/

Qais Yousef (3):
sched/rt: Clean up usage of rt_task()
hrtimer: Convert realtime_task() to realtime_task_policy()
sched/rt, dl: Convert functions to return bool

fs/bcachefs/six.c | 2 +-
fs/select.c | 2 +-
include/linux/ioprio.h | 2 +-
include/linux/sched/deadline.h | 10 ++++++----
include/linux/sched/prio.h | 1 +
include/linux/sched/rt.h | 31 ++++++++++++++++++++++++++++---
kernel/locking/rtmutex.c | 4 ++--
kernel/locking/rwsem.c | 4 ++--
kernel/locking/ww_mutex.h | 2 +-
kernel/sched/core.c | 4 ++--
kernel/sched/syscalls.c | 2 +-
kernel/time/hrtimer.c | 6 +++---
kernel/trace/trace_sched_wakeup.c | 2 +-
mm/page-writeback.c | 4 ++--
mm/page_alloc.c | 2 +-
15 files changed, 53 insertions(+), 25 deletions(-)

--
2.34.1