Re: [PATCH bpf-next v8 1/3] net: Rename mono_delivery_time to tstamp_type for scalabilty

From: Abhishek Chauhan (ABC)
Date: Tue May 28 2024 - 11:35:43 EST




On 5/9/2024 2:18 PM, Abhishek Chauhan wrote:
> mono_delivery_time was added to check if skb->tstamp has delivery
> time in mono clock base (i.e. EDT) otherwise skb->tstamp has
> timestamp in ingress and delivery_time at egress.
>
> Renaming the bitfield from mono_delivery_time to tstamp_type is for
> extensibilty for other timestamps such as userspace timestamp
> (i.e. SO_TXTIME) set via sock opts.
>
> As we are renaming the mono_delivery_time to tstamp_type, it makes
> sense to start assigning tstamp_type based on enum defined
> in this commit.
>
> Earlier we used bool arg flag to check if the tstamp is mono in
> function skb_set_delivery_time, Now the signature of the functions
> accepts tstamp_type to distinguish between mono and real time.
>
> Also skb_set_delivery_type_by_clockid is a new function which accepts
> clockid to determine the tstamp_type.
>
> In future tstamp_type:1 can be extended to support userspace timestamp
> by increasing the bitfield.
>
> Link: https://lore.kernel.org/netdev/bc037db4-58bb-4861-ac31-a361a93841d3@xxxxxxxxx/
> Signed-off-by: Abhishek Chauhan <quic_abchauha@xxxxxxxxxxx>
> Reviewed-by: Willem de Bruijn <willemb@xxxxxxxxxx>
> Reviewed-by: Martin KaFai Lau <martin.lau@xxxxxxxxxx>
> ---
> Changes since v7
> - Added reviewed by tags and removed RFC
>
> Changes since v6
> - Moved documentation comment from patch 2 to patch 1 (Minor)
> - Instead of calling the wrapper api to set tstamp_type
> for tcp, directly call main api to set the tstamp_type
> as suggested by Willem
>
> Changes since v5
> - Avoided using garble function names as mentioned by
> Willem.
> - Implemented a conversion function stead of duplicating
> the same logic as mentioned by Willem.
> - Fixed indentation problems and minor documentation issues
> which mentions tstamp_type as a whole instead of bitfield
> notations. (Mentioned both by Willem and Martin)
>
> Changes since v4
> - Introduce new function to directly delivery_time and
> another to set tstamp_type based on clockid.
> - Removed un-necessary comments in skbuff.h as
> enums were obvious and understood.
>
> Changes since v3
> - Fixed inconsistent capitalization in skbuff.h
> - remove reference to MONO_DELIVERY_TIME_MASK in skbuff.h
> and point it to skb_tstamp_type now.
> - Explicitely setting SKB_CLOCK_MONO if valid transmit_time
> ip_send_unicast_reply
> - Keeping skb_tstamp inline with skb_clear_tstamp.
> - skb_set_delivery_time checks if timstamp is 0 and
> sets the tstamp_type to SKB_CLOCK_REAL.
> - Above comments are given by Willem
> - Found out that skbuff.h has access to uapi/linux/time.h
> So now instead of using CLOCK_REAL/CLOCK_MONO
> i am checking actual clockid_t directly to set tstamp_type
> example:- CLOCK_REALTIME/CLOCK_MONOTONIC
> - Compilation error fixed in
> net/ieee802154/6lowpan/reassembly.c
>
> Changes since v2
> - Minor changes to commit subject
>
> Changes since v1
> - Squashed the two commits into one as mentioned by Willem.
> - Introduced switch in skb_set_delivery_time.
> - Renamed and removed directionality aspects w.r.t tstamp_type
> as mentioned by Willem.
>
>
> include/linux/skbuff.h | 52 ++++++++++++++++------
> include/net/inet_frag.h | 4 +-
> net/bridge/netfilter/nf_conntrack_bridge.c | 6 +--
> net/core/dev.c | 2 +-
> net/core/filter.c | 10 ++---
> net/ieee802154/6lowpan/reassembly.c | 2 +-
> net/ipv4/inet_fragment.c | 2 +-
> net/ipv4/ip_fragment.c | 2 +-
> net/ipv4/ip_output.c | 9 ++--
> net/ipv4/tcp_output.c | 14 +++---
> net/ipv6/ip6_output.c | 6 +--
> net/ipv6/netfilter.c | 6 +--
> net/ipv6/netfilter/nf_conntrack_reasm.c | 2 +-
> net/ipv6/reassembly.c | 2 +-
> net/ipv6/tcp_ipv6.c | 2 +-
> net/sched/act_bpf.c | 4 +-
> net/sched/cls_bpf.c | 4 +-
> 17 files changed, 78 insertions(+), 51 deletions(-)
>
> diff --git a/include/linux/skbuff.h b/include/linux/skbuff.h
> index 1c2902eaebd3..05aec712d16d 100644
> --- a/include/linux/skbuff.h
> +++ b/include/linux/skbuff.h
> @@ -706,6 +706,11 @@ typedef unsigned int sk_buff_data_t;
> typedef unsigned char *sk_buff_data_t;
> #endif
>
> +enum skb_tstamp_type {
> + SKB_CLOCK_REALTIME,
> + SKB_CLOCK_MONOTONIC,
> +};
> +
> /**
> * DOC: Basic sk_buff geometry
> *
> @@ -823,10 +828,8 @@ typedef unsigned char *sk_buff_data_t;
> * @dst_pending_confirm: need to confirm neighbour
> * @decrypted: Decrypted SKB
> * @slow_gro: state present at GRO time, slower prepare step required
> - * @mono_delivery_time: When set, skb->tstamp has the
> - * delivery_time in mono clock base (i.e. EDT). Otherwise, the
> - * skb->tstamp has the (rcv) timestamp at ingress and
> - * delivery_time at egress.
> + * @tstamp_type: When set, skb->tstamp has the
> + * delivery_time clock base of skb->tstamp.
> * @napi_id: id of the NAPI struct this skb came from
> * @sender_cpu: (aka @napi_id) source CPU in XPS
> * @alloc_cpu: CPU which did the skb allocation.
> @@ -954,7 +957,7 @@ struct sk_buff {
> /* private: */
> __u8 __mono_tc_offset[0];
> /* public: */
> - __u8 mono_delivery_time:1; /* See SKB_MONO_DELIVERY_TIME_MASK */
> + __u8 tstamp_type:1; /* See skb_tstamp_type */
> #ifdef CONFIG_NET_XGRESS
> __u8 tc_at_ingress:1; /* See TC_AT_INGRESS_MASK */
> __u8 tc_skip_classify:1;
> @@ -4179,7 +4182,7 @@ static inline void skb_get_new_timestampns(const struct sk_buff *skb,
> static inline void __net_timestamp(struct sk_buff *skb)
> {
> skb->tstamp = ktime_get_real();
> - skb->mono_delivery_time = 0;
> + skb->tstamp_type = SKB_CLOCK_REALTIME;
> }
>
> static inline ktime_t net_timedelta(ktime_t t)
> @@ -4188,10 +4191,33 @@ static inline ktime_t net_timedelta(ktime_t t)
> }
>
> static inline void skb_set_delivery_time(struct sk_buff *skb, ktime_t kt,
> - bool mono)
> + u8 tstamp_type)
> {
> skb->tstamp = kt;
> - skb->mono_delivery_time = kt && mono;
> +
> + if (kt)
> + skb->tstamp_type = tstamp_type;
> + else
> + skb->tstamp_type = SKB_CLOCK_REALTIME;
> +}
> +
> +static inline void skb_set_delivery_type_by_clockid(struct sk_buff *skb,
> + ktime_t kt, clockid_t clockid)
> +{
> + u8 tstamp_type = SKB_CLOCK_REALTIME;
> +
> + switch (clockid) {
> + case CLOCK_REALTIME:
> + break;
> + case CLOCK_MONOTONIC:
> + tstamp_type = SKB_CLOCK_MONOTONIC;
> + break;
> + default:

Willem and Martin, I was thinking we should remove this warn_on_once from below line. Some systems also use panic on warn.
So i think this might result in unnecessary crashes.

Let me know what you think.

Logs which are complaining.
https://syzkaller.appspot.com/x/log.txt?x=118c3ae8980000

> + WARN_ON_ONCE(1);
> + kt = 0;
> + }
> +
> + skb_set_delivery_time(skb, kt, tstamp_type);
> }
>