Re: [PATCH] ASoC: qcom: x1e80100: Add USB DisplayPort plug support

From: Johan Hovold
Date: Tue Jun 04 2024 - 06:46:02 EST


On Tue, Jun 04, 2024 at 11:46:38AM +0200, Krzysztof Kozlowski wrote:
> Add support for handling jack events of USB (DisplayPort).

> Depends on:
> https://lore.kernel.org/all/20240422134354.89291-1-srinivas.kandagatla@xxxxxxxxxx/
> ---

> @@ -20,12 +20,32 @@ struct x1e80100_snd_data {
> struct snd_soc_card *card;
> struct sdw_stream_runtime *sruntime[AFE_PORT_MAX];
> struct snd_soc_jack jack;
> + struct snd_soc_jack hdmi_jack[8];

As I asked Srini, please rename this dp_jack.

> bool jack_setup;
> };
>
> static int x1e80100_snd_init(struct snd_soc_pcm_runtime *rtd)
> {
> struct x1e80100_snd_data *data = snd_soc_card_get_drvdata(rtd->card);
> + struct snd_soc_dai *cpu_dai = snd_soc_rtd_to_cpu(rtd, 0);

> + struct snd_soc_jack *hdmi_jack = NULL;
> + int hdmi_pcm_id = 0;

And use dp_ prefixes here too.

> +
> + switch (cpu_dai->id) {
> + case DISPLAY_PORT_RX_0:
> + hdmi_pcm_id = 0;
> + hdmi_jack = &data->hdmi_jack[hdmi_pcm_id];
> + break;
> + case DISPLAY_PORT_RX_1 ... DISPLAY_PORT_RX_7:
> + hdmi_pcm_id = cpu_dai->id - DISPLAY_PORT_RX_1 + 1;
> + hdmi_jack = &data->hdmi_jack[hdmi_pcm_id];
> + break;
> + default:
> + break;
> + }
> +
> + if (hdmi_jack)
> + return qcom_snd_dp_jack_setup(rtd, hdmi_jack, hdmi_pcm_id);
>
> return qcom_snd_wcd_jack_setup(rtd, &data->jack, &data->jack_setup);
> }

Johan