[PATCH -next 1/2] function_graph: Add kernel-doc comments for ftrace_graph_ret_addr() function

From: Yang Li
Date: Fri Jun 07 2024 - 04:50:14 EST


Added kernel-doc comments for the ftrace_graph_ret_addr() function to
improve code documentation and readability.

Reported-by: Abaci Robot <abaci@xxxxxxxxxxxxxxxxx>
Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=9299
Signed-off-by: Yang Li <yang.lee@xxxxxxxxxxxxxxxxx>
---
kernel/trace/fgraph.c | 6 ++++++
1 file changed, 6 insertions(+)

diff --git a/kernel/trace/fgraph.c b/kernel/trace/fgraph.c
index a13551a023aa..4ad33e4cb8da 100644
--- a/kernel/trace/fgraph.c
+++ b/kernel/trace/fgraph.c
@@ -872,6 +872,12 @@ ftrace_graph_get_ret_stack(struct task_struct *task, int idx)
/**
* ftrace_graph_ret_addr - convert a potentially modified stack return address
* to its original value
+ * @task: pointer to the task_struct of the task being examined
+ * @idx: pointer to a state variable, should be initialized to zero
+ * before the first call
+ * @ret: the current return address found on the stack
+ * @retp: pointer to the return address on the stack, ignored if
+ * HAVE_FUNCTION_GRAPH_RET_ADDR_PTR is not defined
*
* This function can be called by stack unwinding code to convert a found stack
* return address ('ret') to its original value, in case the function graph
--
2.20.1.7.g153144c