Re: [PATCH] mm: introduce pmd|pte_need_soft_dirty_wp helpers for softdirty write-protect

From: Barry Song
Date: Fri Jun 07 2024 - 05:01:08 EST


On Fri, Jun 7, 2024 at 8:46 PM David Hildenbrand <david@xxxxxxxxxx> wrote:
>
> On 06.06.24 05:40, Barry Song wrote:
> > From: Barry Song <v-songbaohua@xxxxxxxx>
> >
> > This patch introduces the pte_need_soft_dirty_wp and
> > pmd_need_soft_dirty_wp helpers to determine if write protection is
> > required for softdirty tracking. This can enhance code readability
> > and improve its overall appearance.
> >
> > These new helpers are utilized in gup, huge_memory, and protect,
> > and are particularly applied in do_swap_page() to optimize a
> > softdirty scenario where mkwrite can still be performed.
>
> [...]
>
> > +static inline bool pmd_need_soft_dirty_wp(struct vm_area_struct *vma, pmd_t pmd)
> > +{
> > + return vma_soft_dirty_enabled(vma) && !pmd_soft_dirty(pmd);
> > +}
> > +
> > +static inline bool pte_need_soft_dirty_wp(struct vm_area_struct *vma, pte_t pte)
> > +{
> > + return vma_soft_dirty_enabled(vma) && !pte_soft_dirty(pte);
> > +}
> > +
>
> Should these be "needs" ? I tend to like these names/semantics.

yes. "needs" is better. Glad to know you have the common liking
for these names.

>
>
> > static inline void vma_iter_config(struct vma_iterator *vmi,
> > unsigned long index, unsigned long last)
> > {
> > diff --git a/mm/memory.c b/mm/memory.c
> > index db9130488231..6307c43796aa 100644
> > --- a/mm/memory.c
> > +++ b/mm/memory.c
> > @@ -4322,7 +4322,7 @@ vm_fault_t do_swap_page(struct vm_fault *vmf)
> > if (!folio_test_ksm(folio) &&
> > (exclusive || folio_ref_count(folio) == 1)) {
> > if ((vma->vm_flags & VM_WRITE) && !userfaultfd_pte_wp(vma, pte) &&
> > - !vma_soft_dirty_enabled(vma)) {
> > + !pte_need_soft_dirty_wp(vma, pte)) {
> > pte = pte_mkwrite(pte, vma);
>
> I would move that into a separate patch, as it's not a simple conversion.
>

cool. will separate it in v2.

> --
> Cheers,
>
> David / dhildenb
>

Thanks
Barry