Re: [PATCH] Input: touchscreen - use sizeof(*pointer) instead of sizeof(type)

From: Dmitry Torokhov
Date: Sun Jun 09 2024 - 17:41:21 EST


On Sat, Jun 08, 2024 at 04:34:49PM +0200, Erick Archer wrote:
> It is preferred to use sizeof(*pointer) instead of sizeof(type)
> due to the type of the variable can change and one needs not
> change the former (unlike the latter).
>
> The refactoring is mostly trivial except for "usbtouchscreen.c"
> file. Here, in the "mtouch_alloc" and "nexio_alloc" functions,
> it is necessary to use a variable with a predefined type instead
> of the "usbtouch->priv" variable (void * type). This way, the
> "sizeof" operator can now know the correct size. Moreover, we
> need to set the "usbtouch->priv" pointer after the memory
> allocation since now the "kmalloc" return value is not assigned
> directly.
>
> This patch has no effect on runtime behavior.
>
> Signed-off-by: Erick Archer <erick.archer@xxxxxxxxxxx>

Applied, thank you.

--
Dmitry