Re: [PATCH -next 2/2] ftrace: Add kernel-doc comments for unregister_ftrace_direct() function

From: Steven Rostedt
Date: Mon Jun 10 2024 - 18:18:10 EST


On Fri, 7 Jun 2024 16:49:57 +0800
Yang Li <yang.lee@xxxxxxxxxxxxxxxxx> wrote:

> Added kernel-doc comments for the unregister_ftrace_direct() function to
> improve code documentation and readability.
>

Someone else beat you to this.

-- Steve

> Reported-by: Abaci Robot <abaci@xxxxxxxxxxxxxxxxx>
> Closes: https://bugzilla.openanolis.cn/show_bug.cgi?id=9300
> Signed-off-by: Yang Li <yang.lee@xxxxxxxxxxxxxxxxx>
> ---
> kernel/trace/ftrace.c | 2 ++
> 1 file changed, 2 insertions(+)
>
> diff --git a/kernel/trace/ftrace.c b/kernel/trace/ftrace.c
> index 4aeb1183ea9f..3b0dbd55cc05 100644
> --- a/kernel/trace/ftrace.c
> +++ b/kernel/trace/ftrace.c
> @@ -5988,6 +5988,8 @@ EXPORT_SYMBOL_GPL(register_ftrace_direct);
> * unregister_ftrace_direct - Remove calls to custom trampoline
> * previously registered by register_ftrace_direct for @ops object.
> * @ops: The address of the struct ftrace_ops object
> + * @addr: The address of the direct call to remove
> + * @free_filters: Boolean indicating whether to free the filters
> *
> * This is used to remove a direct calls to @addr from the nop locations
> * of the functions registered in @ops (with by ftrace_set_filter_ip