Re: [PATCH v3 3/5] platform/chrome: cros_ec_proto: Introduce cros_ec_cmd_versions()

From: Thomas Weißschuh
Date: Tue Jun 11 2024 - 08:14:49 EST


On 2024-06-11 11:35:39+0000, Tzung-Bi Shih wrote:
> On Mon, Jun 10, 2024 at 05:51:08PM +0200, Thomas Weißschuh wrote:
> > +/**
> > + * cros_ec_cmd_versions - Get supported version mask.
>
> I guess we would like to call it something like "cros_ec_get_cmd_versions".

Ack.

> > + *
> > + * @ec_dev: EC device
> > + * @cmd: Command to test
> > + *
> > + * Return: version mask on success, negative error number on failure.
> > + */
> > +int cros_ec_cmd_versions(struct cros_ec_device *ec_dev, u16 cmd)
>
> Could it support a "version" parameter as existing EC_CMD_GET_CMD_VERSIONS
> usages use both versions? An `u16 cmd` parameter and down-cast to u8 for v0
> should be fine. (ec_params_get_cmd_versions vs. ec_params_get_cmd_versions_v1)

Ack.

Or we could automatically use v0 if cmd <= U8_MAX?