Re: [PATCH 1/2] dt-bindings: i3c: dw: Add clock binding

From: Conor Dooley
Date: Tue Jun 11 2024 - 14:10:55 EST


On Tue, Jun 11, 2024 at 05:15:59PM +0000, Aniket wrote:
> Add dt binding for optional apb clock.
> Core clock is mandatory. Also add
> an example.

Please fix your line wrapping here.

> Signed-off-by: Aniket <aniketmaurya@xxxxxxxxxx>

Full name please.

> ---
> .../bindings/i3c/snps,dw-i3c-master.yaml | 19 ++++++++++++++++++-
> 1 file changed, 18 insertions(+), 1 deletion(-)
>
> diff --git a/Documentation/devicetree/bindings/i3c/snps,dw-i3c-master.yaml b/Documentation/devicetree/bindings/i3c/snps,dw-i3c-master.yaml
> index c0e805e531be..7e3d4f308477 100644
> --- a/Documentation/devicetree/bindings/i3c/snps,dw-i3c-master.yaml
> +++ b/Documentation/devicetree/bindings/i3c/snps,dw-i3c-master.yaml
> @@ -20,7 +20,16 @@ properties:
> maxItems: 1
>
> clocks:
> - maxItems: 1
> + minItems: 1
> + items:
> + - description: Core interface clock

s/interface //.

> + - description: APB interface clock
> +
> + clock-names:
> + minItems: 1
> + items:
> + - const: core_clk
> + - const: pclk

Why not name them "core" and "apb"? Putting "clk" in both names is
redundant infomration, we already know they're clocks.

>
> interrupts:
> maxItems: 1
> @@ -49,4 +58,12 @@ examples:
> pagesize = <0x8>;
> };
> };
> + - |
> + i3c@10400 {

No need for an extra example for this.

Thanks,
Conor.

> + compatible = "snps,dw-i3c-master-1.00a";
> + reg = <0x10400 0x1000>;
> + interrupts = <8>;
> + clocks = <&i3c0_cclk>,<&i3c0_pclk>;
^^
missing a space here.

> + clock-names = "core_clk", "pclk";
> + };
> ...
> --
> 2.45.2.505.gda0bf45e8d-goog
>
>

Attachment: signature.asc
Description: PGP signature