In an effort to support MBM and MBA tests for AMD, renaming for variable
and functions to generic names. For Intel, the memory controller is called
Integrated Memory Controllers (IMC). For AMD, it is called Unified
Memory Controller (UMC).
Change the names of variables and functions from imc (Integrated memory
controller) to mc(Memory Controller). No functional change.
Signed-off-by: Babu Moger <babu.moger@xxxxxxx>
---
@@ -349,10 +350,10 @@ static void do_imc_mem_bw_test(void)
*
* Return: = 0 on success. < 0 on failure.
*/
-static int get_mem_bw_imc(const char *bw_report, float *bw_imc)
+static int get_mem_bw_mc(const char *bw_report, float *bw_mc)
{
float reads, writes, of_mul_read, of_mul_write;
- int imc;
+ int mc;
/* Start all iMC counters to log values (both read and write) */
reads = 0, writes = 0, of_mul_read = 1, of_mul_write = 1;
@@ -361,21 +362,21 @@ static int get_mem_bw_imc(const char *bw_report, float *bw_imc)
* Get results which are stored in struct type imc_counter_config
* Take overflow into consideration before calculating total bandwidth.
*/
- for (imc = 0; imc < imcs; imc++) {
- struct imc_counter_config *r =
- &imc_counters_config[imc][READ];
- struct imc_counter_config *w =
- &imc_counters_config[imc][WRITE];
+ for (mc = 0; mc < mcs; mc++) {
+ struct mc_counter_config *r =
+ &mc_counters_config[mc][READ];
+ struct mc_counter_config *w =
+ &mc_counters_config[mc][WRITE];