[PATCH 00/10] hwmon: (amc6821) Various improvements
From: Guenter Roeck
Date: Fri Jun 28 2024 - 11:14:03 EST
Cleanup and modernize the amc2821 driver.
Changes introducing or modifying functionality:
- Stop accepting invalid pwm values.
- Improve consistency of reading vs. writing fan speed limits
- Rename fan1_div to fan1_pulses
- Add support for fan1_target and a new pwm1_enable mode 4
Non-functional changes:
- Reorder include files, drop unnecessary ones
- Use tabs for column alignment in defines
- Use BIT() and GENMASK()
- Drop unnecessary enum chips
- Convert to use regmap
- Convert to with_info API
The series was tested with module test scripts at
git@xxxxxxxxxx:groeck/module-tests.git.
----------------------------------------------------------------
Guenter Roeck (10):
hwmon: (amc6821) Stop accepting invalid pwm values
hwmon: (amc6821) Make reading and writing fan speed limits consistent
hwmon: (amc6821) Rename fan1_div to fan1_pulses
hwmon: (amc6821) Add support for fan1_target and pwm1_enable mode 4
hwmon: (amc2821) Reorder include files, drop unnecessary ones
hwmon: (amc6821) Use tabs for column alignment in defines
hwmon: (amc2821) Use BIT() and GENMASK()
hwmon: (amc6821) Drop unnecessary enum chips
hwmon: (amc6821) Convert to use regmap
hwmon: (amc6821) Convert to with_info API
Documentation/hwmon/amc6821.rst | 6 +-
drivers/hwmon/Kconfig | 1 +
drivers/hwmon/amc6821.c | 1274 +++++++++++++++++++--------------------
3 files changed, 637 insertions(+), 644 deletions(-)