[PATCH v1] thermal: core: Simplify list sorting in __thermal_zone_device_update()

From: Rafael J. Wysocki
Date: Fri Jul 05 2024 - 16:22:47 EST


From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>

Notice that it is not necessary to sort way_down_list in descending
order. Instead, it can be sorted in ascending order, like way_up_list,
and walked in reverse order.

Use this observation to simplify list sorting slightly in
__thermal_zone_device_update() which also causes the code to
be somewhat more straightforward and so easier to follow.

Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
---
drivers/thermal/thermal_core.c | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

Index: linux-pm/drivers/thermal/thermal_core.c
===================================================================
--- linux-pm.orig/drivers/thermal/thermal_core.c
+++ linux-pm/drivers/thermal/thermal_core.c
@@ -487,16 +487,14 @@ static void thermal_trip_crossed(struct
thermal_governor_trip_crossed(governor, tz, trip, crossed_up);
}

-static int thermal_trip_notify_cmp(void *ascending, const struct list_head *a,
+static int thermal_trip_notify_cmp(void *not_used, const struct list_head *a,
const struct list_head *b)
{
struct thermal_trip_desc *tda = container_of(a, struct thermal_trip_desc,
notify_list_node);
struct thermal_trip_desc *tdb = container_of(b, struct thermal_trip_desc,
notify_list_node);
- int ret = tdb->notify_temp - tda->notify_temp;
-
- return ascending ? ret : -ret;
+ return tdb->notify_temp - tda->notify_temp;
}

void __thermal_zone_device_update(struct thermal_zone_device *tz,
@@ -525,12 +523,12 @@ void __thermal_zone_device_update(struct

thermal_zone_set_trips(tz);

- list_sort(&way_up_list, &way_up_list, thermal_trip_notify_cmp);
+ list_sort(NULL, &way_up_list, thermal_trip_notify_cmp);
list_for_each_entry(td, &way_up_list, notify_list_node)
thermal_trip_crossed(tz, &td->trip, governor, true);

list_sort(NULL, &way_down_list, thermal_trip_notify_cmp);
- list_for_each_entry(td, &way_down_list, notify_list_node)
+ list_for_each_entry_reverse(td, &way_down_list, notify_list_node)
thermal_trip_crossed(tz, &td->trip, governor, false);

if (governor->manage)