[PATCH] lib/bch.c: Use swap() to improve code

From: Thorsten Blum
Date: Mon Jul 08 2024 - 18:41:40 EST


Use the swap() macro to simplify the functions solve_linear_system()
and gf_poly_gcd() and improve their readability. Remove the local
variable tmp.

Fixes the following three Coccinelle/coccicheck warnings reported by
swap.cocci:

WARNING opportunity for swap()
WARNING opportunity for swap()
WARNING opportunity for swap()

Compile-tested only.

Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxxx>
---
lib/bch.c | 20 +++++---------------
1 file changed, 5 insertions(+), 15 deletions(-)

diff --git a/lib/bch.c b/lib/bch.c
index 5f71fd76eca8..1c0cb07cdfeb 100644
--- a/lib/bch.c
+++ b/lib/bch.c
@@ -479,11 +479,8 @@ static int solve_linear_system(struct bch_control *bch, unsigned int *rows,
/* find suitable row for elimination */
for (r = p; r < m; r++) {
if (rows[r] & mask) {
- if (r != p) {
- tmp = rows[r];
- rows[r] = rows[p];
- rows[p] = tmp;
- }
+ if (r != p)
+ swap(rows[r], rows[p]);
rem = r+1;
break;
}
@@ -799,21 +796,14 @@ static void gf_poly_div(struct bch_control *bch, struct gf_poly *a,
static struct gf_poly *gf_poly_gcd(struct bch_control *bch, struct gf_poly *a,
struct gf_poly *b)
{
- struct gf_poly *tmp;
-
dbg("gcd(%s,%s)=", gf_poly_str(a), gf_poly_str(b));

- if (a->deg < b->deg) {
- tmp = b;
- b = a;
- a = tmp;
- }
+ if (a->deg < b->deg)
+ swap(a, b);

while (b->deg > 0) {
gf_poly_mod(bch, a, b, NULL);
- tmp = b;
- b = a;
- a = tmp;
+ swap(a, b);
}

dbg("%s\n", gf_poly_str(a));
--
2.45.2