[PATCH 0/3] kunit: Improve the readability and functionality of macro.

From: Eric Chan
Date: Wed Jul 10 2024 - 13:05:23 EST


This series let kunit macro more neat and clear.
Fix comment and rename the macro.
Also introduce new type of assertion marco for functionality.

Eric Chan (3):
kunit: Fix the comment of KUNIT_ASSERT_STRNEQ as assertion
kunit: Rename KUNIT_ASSERT_FAILURE to KUNIT_ASSERT for readability
kunit: Introduce KUNIT_ASSERT_MEMEQ and KUNIT_ASSERT_MEMNEQ macros

drivers/input/tests/input_test.c | 2 +-
include/kunit/assert.h | 2 +-
include/kunit/test.h | 71 ++++++++++++++++++++++++++++++--
3 files changed, 70 insertions(+), 5 deletions(-)

--
2.45.2.803.g4e1b14247a-goog