[PATCH 0/3] Some cleanups for shmem

From: Baolin Wang
Date: Thu Jul 11 2024 - 01:43:18 EST


Hi,

This series does some cleanups to reuse code, rename functions and simplify
logic to make code more clear. No functional changes are expected.

Baolin Wang (3):
mm: shmem: simplify the suitable huge orders validation for tmpfs
mm: shmem: rename shmem_is_huge() to shmem_huge_global_enabled()
mm: shmem: move shmem_huge_global_enabled() into
shmem_allowable_huge_orders()

include/linux/shmem_fs.h | 11 +-----
mm/huge_memory.c | 11 ++----
mm/shmem.c | 84 ++++++++++++++++++++--------------------
3 files changed, 46 insertions(+), 60 deletions(-)

--
2.39.3