Re: [PATCH 2/2] dma: Add IOMMU static calls with clear default ops

From: Leon Romanovsky
Date: Sat Jul 13 2024 - 05:30:59 EST


On Fri, Jul 12, 2024 at 01:51:36PM -0700, Easwar Hariharan wrote:
> On 7/11/2024 3:38 AM, Leon Romanovsky wrote:
> > From: Leon Romanovsky <leonro@xxxxxxxxxx>
> >
> > Most of the IOMMU drivers are using the same DMA operations, which are
> > default ones implemented in drivers/iomem/dma-iomem.c. So it makes sense
> > to properly set them as a default with direct call without need to
> > perform function pointer dereference.
> >
> > During system initialization, the IOMMU driver can set its own DMA and
> > in such case, the default DMA operations will be overridden.
> >
> > Signed-off-by: Leon Romanovsky <leonro@xxxxxxxxxx>
> > ---
> > MAINTAINERS | 1 +
> > drivers/iommu/dma-iommu.c | 24 +++++++-------
> > include/linux/iommu-dma.h | 50 +++++++++++++++++++++++++++++
> > kernel/dma/iommu.h | 67 +++++++++++++++++++++++++++++++++++++++
> > kernel/dma/mapping.c | 9 +++---
> > 5 files changed, 134 insertions(+), 17 deletions(-)
> > create mode 100644 include/linux/iommu-dma.h
> > create mode 100644 kernel/dma/iommu.h
> >
>
> <snip>
> > diff --git a/include/linux/iommu-dma.h b/include/linux/iommu-dma.h
> > new file mode 100644
> > index 000000000000..b42487bf8f8e
> > --- /dev/null
> > +++ b/include/linux/iommu-dma.h
> > @@ -0,0 +1,50 @@
> > +/* SPDX-License-Identifier: GPL-2.0 */
> > +/*
> > + * Copyright (c) 2024, NVIDIA CORPORATION & AFFILIATES. All rights reserved
> > + *
> > + * DMA operations that map physical memory through IOMMU.
> > + */
> > +#ifndef _LINUX_IOMMU_DMA_H
> > +#define _LINUX_IOMMU_DMA_H
> > +
> > +#include <linux/dma-direction.h>
> > +
> > +#ifdef CONFIG_IOMMU_API
> > +dma_addr_t iommu_dma_map_page(struct device *dev, struct page *page,
> > + unsigned long offset, size_t size,
> > + enum dma_data_direction dir, unsigned long attrs);
> > +void iommu_dma_unmap_page(struct device *dev, dma_addr_t dma_handle,
> > + size_t size, enum dma_data_direction dir,
> > + unsigned long attrs);
> > +int iommu_dma_map_sg(struct device *dev, struct scatterlist *sg, int nents,
> > + enum dma_data_direction dir, unsigned long attrs);
> > +void iommu_dma_unmap_sg(struct device *dev, struct scatterlist *sg, int nents,
> > + enum dma_data_direction dir, unsigned long attrs);
> > +#else
> > +static inline dma_addr_t iommu_dma_map_page(struct device *dev,
> > + struct page *page,
> > + unsigned long offset, size_t size,
> > + enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + return DMA_MAPPING_ERROR;
> > +}
> > +static inline void iommu_dma_unmap_page(struct device *dev,
> > + dma_addr_t dma_handle, size_t size,
> > + enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > +}
> > +static inline int iommu_dma_map_sg(struct device *dev, struct scatterlist *sg,
> > + int nents, enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + return -EINVAL;
> > +}
> > +static void iommu_dma_unmap_sg(struct device *dev, struct scatterlist *sg,
> > + int nents, enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > +}
> > +#endif /* CONFIG_IOMMU_API */
> > +#endif /* _LINUX_IOMMU_DMA_H */
> > diff --git a/kernel/dma/iommu.h b/kernel/dma/iommu.h
> > new file mode 100644
> > index 000000000000..4abaea2dfc49
> > --- /dev/null
> > +++ b/kernel/dma/iommu.h
> > @@ -0,0 +1,67 @@
> > +/* SPDX-License-Identifier: GPL-2.0 */
> > +/*
> > + * Copyright (c) 2024, NVIDIA CORPORATION & AFFILIATES. All rights reserved
> > + *
> > + * DMA operations that map physical memory through IOMMU.
> > + */
> > +#ifndef _KERNEL_DMA_IOMMU_H
> > +#define _KERNEL_DMA_IOMMU_H
> > +
> > +#include <linux/iommu-dma.h>
> > +
> > +static inline dma_addr_t dma_iommu_map_page(struct device *dev,
> > + struct page *page, size_t offset,
> > + size_t size,
> > + enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + const struct dma_map_ops *ops = get_dma_ops(dev);
> > +
> > + if (ops->map_page)
> > + return ops->map_page(dev, page, offset, size, dir, attrs);
> > +
> > + return iommu_dma_map_page(dev, page, offset, size, dir, attrs);
> > +}
> > +
> > +static inline void dma_iommu_unmap_page(struct device *dev, dma_addr_t addr,
> > + size_t size,
> > + enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + const struct dma_map_ops *ops = get_dma_ops(dev);
> > +
> > + if (ops->unmap_page) {
> > + ops->unmap_page(dev, addr, size, dir, attrs);
> > + return;
> > + }
> > +
> > + iommu_dma_unmap_page(dev, addr, size, dir, attrs);
> > +}
> > +
> > +static inline int dma_iommu_map_sg(struct device *dev, struct scatterlist *sg,
> > + int nents, enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + const struct dma_map_ops *ops = get_dma_ops(dev);
> > +
> > + if (ops->map_sg)
> > + return ops->map_sg(dev, sg, nents, dir, attrs);
> > +
> > + return iommu_dma_map_sg(dev, sg, nents, dir, attrs);
> > +}
> > +
> > +static inline void dma_iommu_unmap_sg(struct device *dev,
> > + struct scatterlist *sg, int nents,
> > + enum dma_data_direction dir,
> > + unsigned long attrs)
> > +{
> > + const struct dma_map_ops *ops = get_dma_ops(dev);
> > +
> > + if (ops->unmap_sg) {
> > + ops->unmap_sg(dev, sg, nents, dir, attrs);
> > + return;
> > + }
> > +
> > + iommu_dma_unmap_sg(dev, sg, nents, dir, attrs);
> > +}
>
> Can we use _dma_iommu_* instead of the transposition pattern we have
> going on here? Having dma_iommu_* call iommu_dma_* is, I feel, a recipe
> for confusion when reading the code, especially after a few passes when
> the eyes start to glaze over.
>
> I think you're going for the typical pattern of iommu_dma* being an
> internal detail that provides an implementation, but correct me if
> there's some significance to the current naming scheme.

Given the review feedback from Robin and Christoph, I will drop this
layer anyway.

Thanks

>
> Thanks,
> Easwar