[PATCH v3 0/3] Some cleanups for shmem

From: Baolin Wang
Date: Mon Jul 22 2024 - 01:44:13 EST


Hi,

This series does some cleanups to reuse code, rename functions and simplify
logic to make code more clear. No functional changes are expected.

Changes from v2:
- Add reviewed tag from Ryan. Thanks.
- Pass vma instead of mm to shmem_huge_global_enabled(), per Ryan.

Changes from v1:
- Add a dummy function in case CONFIG_TRANSPARENT_HUGEPAGE is not
enabled, which fixes a building error reported by kernel test robot.

Baolin Wang (3):
mm: shmem: simplify the suitable huge orders validation for tmpfs
mm: shmem: rename shmem_is_huge() to shmem_huge_global_enabled()
mm: shmem: move shmem_huge_global_enabled() into
shmem_allowable_huge_orders()

include/linux/shmem_fs.h | 11 +----
mm/huge_memory.c | 11 ++---
mm/shmem.c | 93 +++++++++++++++++++++-------------------
3 files changed, 54 insertions(+), 61 deletions(-)

--
2.39.3