Re: [PATCH v3 25/25] context_tracking, rcu: Rename rcu_dyntick trace event into rcu_watching

From: Frederic Weisbecker
Date: Thu Jul 25 2024 - 08:39:28 EST


Le Wed, Jul 24, 2024 at 04:43:25PM +0200, Valentin Schneider a écrit :
> The "rcu_dyntick" naming convention has been turned into "rcu_watching" for
> all helpers now, align the trace event to that.
>
> To add to the confusion, the strings passed to the trace event are now
> reversed: when RCU "starts" the dyntick / EQS state, it "stops" watching.
>
> Signed-off-by: Valentin Schneider <vschneid@xxxxxxxxxx>
> ---
> include/trace/events/rcu.h | 16 ++++++++--------
> kernel/context_tracking.c | 10 +++++-----
> 2 files changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/include/trace/events/rcu.h b/include/trace/events/rcu.h
> index 4066b6d51e46a..e51ef658437f0 100644
> --- a/include/trace/events/rcu.h
> +++ b/include/trace/events/rcu.h
> @@ -466,40 +466,40 @@ TRACE_EVENT(rcu_stall_warning,
> /*
> * Tracepoint for dyntick-idle entry/exit events. These take 2 strings
> * as argument:
> - * polarity: "Start", "End", "StillNonIdle" for entering, exiting or still not
> + * polarity: "Start", "End", "StillWatching" for entering, exiting or still not
> * being in dyntick-idle mode.
> * context: "USER" or "IDLE" or "IRQ".

So that should be:

* polarity: "Start", "End", "StillWatching" for exiting, entering or still not
being in EQS mode.

Right?

Other than that:

Reviewed-by: Frederic Weisbecker <frederic@xxxxxxxxxx>