Re: [PATCH 3/3] rust: sync: Add IrqSpinLock

From: Peter Zijlstra
Date: Fri Jul 26 2024 - 03:50:16 EST


On Thu, Jul 25, 2024 at 06:27:52PM -0400, Lyude Paul wrote:
> A variant of SpinLock that is expected to be used in noirq contexts, and
> thus requires that the user provide an kernel::irq::IrqDisabled to prove
> they are in such a context upon lock acquisition. This is the rust
> equivalent of spin_lock_irqsave()/spin_lock_irqrestore().

So aside from the horrendous camel-case thing, why are you naming this
thing the wrong way around? Shouldn't it be SpinLockIrq rather than
IrqSpinLock? Or possibly even SpinLockIrqSave?

Randomly changing the names of things isn't going to make it any easier
for people to use this stuff.