On Wed, Jul 10, 2024 at 12:06:47PM +0800, libaokun@xxxxxxxxxxxxxxx wrote:Thanks for the review!
From: Baokun Li <libaokun1@xxxxxxxxxx>Looks good Baokun, feel free to add:
The use of path and ppath is now very confusing, so to make the code more
readable, pass path between functions uniformly, and get rid of ppath.
To get rid of the ppath in ext4_force_split_extent_at(), the following is
done here:
* The ext4_find_extent() can update the extent path so it doesn't have to
allocate and free path repeatedly, thus reducing the consumption of
memory allocation and freeing in ext4_swap_extents().
No functional changes.
Reviewed-by: Ojaswin Mujoo <ojaswin@xxxxxxxxxxxxx>
One small comment below..
Totally agree! It does seem a bit unclear now to put the refactoringSigned-off-by: Baokun Li <libaokun1@xxxxxxxxxx>.. snip ..
---
fs/ext4/extents.c | 117 ++++++++++++++++++++++++----------------------
1 file changed, 60 insertions(+), 57 deletions(-)
diff --git a/fs/ext4/extents.c b/fs/ext4/extents.c
index c86b1bb7720f..0bd068ed324f 100644
--- a/fs/ext4/extents.c
+++ b/fs/ext4/extents.c
@@ -5707,25 +5701,21 @@ ext4_swap_extents(handle_t *handle, struct inode *inode1,In ext4_swap_extents, maybe we should keep the refactoring to a separate
patch than the changes needed to get rid of ppath in
ext4_force_split_extent_at(), the commits would look a bit cleaner and
easier to read that way. I don't feel too strongly about it tho and
I'll let you take a call.
Regards,
ojaswin