[PATCH v1] arm: dts: st: stm32mp151a-prtt1l: Fix QSPI configuration

From: Oleksij Rempel
Date: Tue Aug 06 2024 - 08:05:41 EST


Rename 'pins1' to 'pins' in the qspi_bk1_pins_a node to correct the
subnode name. The previous name caused the configuration to be
applied to the wrong subnode, resulting in QSPI not working properly.

Signed-off-by: Oleksij Rempel <o.rempel@xxxxxxxxxxxxxx>
---
arch/arm/boot/dts/st/stm32mp151a-prtt1l.dtsi | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/arm/boot/dts/st/stm32mp151a-prtt1l.dtsi b/arch/arm/boot/dts/st/stm32mp151a-prtt1l.dtsi
index 3938d357e198f..4db684478c320 100644
--- a/arch/arm/boot/dts/st/stm32mp151a-prtt1l.dtsi
+++ b/arch/arm/boot/dts/st/stm32mp151a-prtt1l.dtsi
@@ -123,7 +123,7 @@ flash@0 {
};

&qspi_bk1_pins_a {
- pins1 {
+ pins {
bias-pull-up;
drive-push-pull;
slew-rate = <1>;
--
2.39.2