Re: [PATCH 1/4] perf/x86: Refine hybrid_pmu_type defination

From: Peter Zijlstra
Date: Sat Aug 10 2024 - 17:35:52 EST


On Thu, Aug 08, 2024 at 02:02:07PM +0000, Dapeng Mi wrote:
> Use macros instead of magic number to define hybrid_pmu_type and remove
> X86_HYBRID_NUM_PMUS since it's never used.
>
> Signed-off-by: Dapeng Mi <dapeng1.mi@xxxxxxxxxxxxxxx>
> Tested-by: Yongwei Ma <yongwei.ma@xxxxxxxxx>
> ---
> arch/x86/events/perf_event.h | 11 ++++-------
> 1 file changed, 4 insertions(+), 7 deletions(-)
>
> diff --git a/arch/x86/events/perf_event.h b/arch/x86/events/perf_event.h
> index ac1182141bf6..5d1677844e04 100644
> --- a/arch/x86/events/perf_event.h
> +++ b/arch/x86/events/perf_event.h
> @@ -674,19 +674,16 @@ enum hybrid_cpu_type {
> HYBRID_INTEL_CORE = 0x40,
> };
>
> +#define X86_HYBRID_PMU_ATOM_IDX 0
> +#define X86_HYBRID_PMU_CORE_IDX 1

There wants to be some whitespace here..

> enum hybrid_pmu_type {
> not_hybrid,
> - hybrid_small = BIT(0),
> - hybrid_big = BIT(1),
> + hybrid_small = BIT(X86_HYBRID_PMU_ATOM_IDX),
> + hybrid_big = BIT(X86_HYBRID_PMU_CORE_IDX),
>
> hybrid_big_small = hybrid_big | hybrid_small, /* only used for matching */
> };
>
> -#define X86_HYBRID_PMU_ATOM_IDX 0
> -#define X86_HYBRID_PMU_CORE_IDX 1
> -
> -#define X86_HYBRID_NUM_PMUS 2
> -
> struct x86_hybrid_pmu {
> struct pmu pmu;
> const char *name;
> --
> 2.40.1
>