Re: [RFC net-next 1/6] netdevice: Add napi_affinity_no_change

From: Stanislav Fomichev
Date: Mon Aug 12 2024 - 16:23:39 EST


On 08/12, Joe Damato wrote:
> Several drivers have their own, very similar, implementations of
> determining if IRQ affinity has changed. Create napi_affinity_no_change
> to centralize this logic in the core.
>
> This will be used in following commits for various drivers to eliminate
> duplicated code.
>
> Signed-off-by: Joe Damato <jdamato@xxxxxxxxxx>
> ---
> include/linux/netdevice.h | 8 ++++++++
> net/core/dev.c | 14 ++++++++++++++
> 2 files changed, 22 insertions(+)
>
> diff --git a/include/linux/netdevice.h b/include/linux/netdevice.h
> index 0ef3eaa23f4b..dc714a04b90a 100644
> --- a/include/linux/netdevice.h
> +++ b/include/linux/netdevice.h
> @@ -464,6 +464,14 @@ enum rx_handler_result {
> typedef enum rx_handler_result rx_handler_result_t;
> typedef rx_handler_result_t rx_handler_func_t(struct sk_buff **pskb);
>
> +/**
> + * napi_affinity_no_change - determine if CPU affinity changed
> + * @irq: the IRQ whose affinity may have changed
> + *
> + * Return true if the CPU affinity has NOT changed, false otherwise.
> + */
> +bool napi_affinity_no_change(unsigned int irq);
> +
> void __napi_schedule(struct napi_struct *n);
> void __napi_schedule_irqoff(struct napi_struct *n);
>
> diff --git a/net/core/dev.c b/net/core/dev.c
> index 751d9b70e6ad..9c56ad49490c 100644
> --- a/net/core/dev.c
> +++ b/net/core/dev.c
> @@ -89,6 +89,7 @@
> #include <linux/errno.h>
> #include <linux/interrupt.h>
> #include <linux/if_ether.h>
> +#include <linux/irq.h>
> #include <linux/netdevice.h>
> #include <linux/etherdevice.h>
> #include <linux/ethtool.h>
> @@ -6210,6 +6211,19 @@ void __napi_schedule_irqoff(struct napi_struct *n)
> }
> EXPORT_SYMBOL(__napi_schedule_irqoff);
>
> +bool napi_affinity_no_change(unsigned int irq)
> +{
> + int cpu_curr = smp_processor_id();
> + const struct cpumask *aff_mask;
> +

[..]

> + aff_mask = irq_get_effective_affinity_mask(irq);

Most drivers don't seem to call this on every napi_poll (and
cache the aff_mask somewhere instead). Should we try to keep this
out of the past path as well?