Re: [PATCH v2 2/3] usb: typec: ucsi: Move unregister out of atomic section
From: Johan Hovold
Date: Tue Aug 20 2024 - 02:43:24 EST
On Mon, Aug 19, 2024 at 01:07:46PM -0700, Bjorn Andersson wrote:
> Commit '635ce0db8956 ("soc: qcom: pmic_glink: don't traverse clients
Looks like you copied the wrong SHA again. This should be
9329933699b3 ("soc: qcom: pmic_glink: Make client-lock non-sleeping")
as we discussed.
> list without a lock")' moved the pmic_glink client list under a
> spinlock, as it is accessed by the rpmsg/glink callback, which in turn
> is invoked from IRQ context.
>
> This means that ucsi_unregister() is now called from IRQ context, which
And this should be "atomic context" as pdr notifications are done from
a worker thread.
> isn't feasible as it's expecting a sleepable context. An effort is under
> way to get GLINK to invoke its callbacks in a sleepable context, but
> until then lets schedule the unregistration.
>
> A side effect of this is that ucsi_unregister() can now happen
> after the remote processor, and thereby the communication link with it, is
> gone. pmic_glink_send() is amended with a check to avoid the resulting NULL
> pointer dereference.
> This does however result in the user being informed about this error by
> the following entry in the kernel log:
>
> ucsi_glink.pmic_glink_ucsi pmic_glink.ucsi.0: failed to send UCSI write request: -5
>
> Fixes: 635ce0db8956 ("soc: qcom: pmic_glink: don't traverse clients list without a lock")
Fixes: 9329933699b3 ("soc: qcom: pmic_glink: Make client-lock non-sleeping")
> Cc: stable@xxxxxxxxxxxxxxx
> Reviewed-by: Heikki Krogerus <heikki.krogerus@xxxxxxxxxxxxxxx>
> Reviewed-by: Neil Armstrong <neil.armstrong@xxxxxxxxxx>
> Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@xxxxxxxxxx>
> Tested-by: Amit Pundir <amit.pundir@xxxxxxxxxx>
> Signed-off-by: Bjorn Andersson <quic_bjorande@xxxxxxxxxxx>
> @@ -269,11 +284,12 @@ static void pmic_glink_ucsi_callback(const void *data, size_t len, void *priv)
> static void pmic_glink_ucsi_pdr_notify(void *priv, int state)
> {
> struct pmic_glink_ucsi *ucsi = priv;
> + unsigned long flags;
>
> - if (state == SERVREG_SERVICE_STATE_UP)
> - schedule_work(&ucsi->register_work);
> - else if (state == SERVREG_SERVICE_STATE_DOWN)
> - ucsi_unregister(ucsi->ucsi);
> + spin_lock_irqsave(&ucsi->state_lock, flags);
> + ucsi->pd_running = state == SERVREG_SERVICE_STATE_UP;
Add parentheses for readability?
> + spin_unlock_irqrestore(&ucsi->state_lock, flags);
> + schedule_work(&ucsi->register_work);
> }
>
> static void pmic_glink_ucsi_destroy(void *data)
> @@ -320,6 +336,7 @@ static int pmic_glink_ucsi_probe(struct auxiliary_device *adev,
> INIT_WORK(&ucsi->register_work, pmic_glink_ucsi_register);
> init_completion(&ucsi->read_ack);
> init_completion(&ucsi->write_ack);
> + spin_lock_init(&ucsi->state_lock);
> mutex_init(&ucsi->lock);
>
> ucsi->ucsi = ucsi_create(dev, &pmic_glink_ucsi_ops);
Looks good otherwise:
Reviewed-by: Johan Hovold <johan+linaro@xxxxxxxxxx>
Johan