Re: [PATCH] ocfs2: Use max() to improve ocfs2_dlm_seq_show()
From: Joseph Qi
Date: Tue Aug 20 2024 - 08:18:25 EST
On 8/20/24 10:16 AM, Thorsten Blum wrote:
> Use the max() macro to simplify the ocfs2_dlm_seq_show() function and
> improve its readability.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxxx>
Reviewed-by: Joseph Qi <joseph.qi@xxxxxxxxxxxxxxxxx>
> ---
> fs/ocfs2/dlmglue.c | 7 ++-----
> 1 file changed, 2 insertions(+), 5 deletions(-)
>
> diff --git a/fs/ocfs2/dlmglue.c b/fs/ocfs2/dlmglue.c
> index da78a04d6f0b..60df52e4c1f8 100644
> --- a/fs/ocfs2/dlmglue.c
> +++ b/fs/ocfs2/dlmglue.c
> @@ -3151,11 +3151,8 @@ static int ocfs2_dlm_seq_show(struct seq_file *m, void *v)
> #ifdef CONFIG_OCFS2_FS_STATS
> if (!lockres->l_lock_wait && dlm_debug->d_filter_secs) {
> now = ktime_to_us(ktime_get_real());
> - if (lockres->l_lock_prmode.ls_last >
> - lockres->l_lock_exmode.ls_last)
> - last = lockres->l_lock_prmode.ls_last;
> - else
> - last = lockres->l_lock_exmode.ls_last;
> + last = max(lockres->l_lock_prmode.ls_last,
> + lockres->l_lock_exmode.ls_last);
> /*
> * Use d_filter_secs field to filter lock resources dump,
> * the default d_filter_secs(0) value filters nothing,