Re: [PATCH 01/13] ALSA: pcm: add more sample rate definitions

From: Takashi Iwai
Date: Wed Sep 11 2024 - 06:44:29 EST


On Wed, 11 Sep 2024 11:21:41 +0200,
Takashi Iwai wrote:
>
> On Wed, 11 Sep 2024 11:09:59 +0200,
> Pierre-Louis Bossart wrote:
> >
> >
> >
> > On 9/5/24 16:12, Jerome Brunet wrote:
> > > This adds a sample rate definition for 12kHz, 24kHz and 128kHz.
> > >
> > > Admittedly, just a few drivers are currently using these sample
> > > rates but there is enough of a recurrence to justify adding a definition
> > > for them and remove some custom rate constraint code while at it.
> > >
> > > The new definitions are not added to the interval definitions, such as
> > > SNDRV_PCM_RATE_8000_44100, because it would silently add new supported
> > > rates to drivers that may or may not support them. For sure the drivers
> > > have not been tested for these new rates so it is better to leave them out
> > > of interval definitions.
> > >
> > > That being said, the added rates are multiples of well know rates families,
> > > it is very likely that a lot of devices out there actually supports them.
> > >
> > > Signed-off-by: Jerome Brunet <jbrunet@xxxxxxxxxxxx>
> > > ---
> > > include/sound/pcm.h | 31 +++++++++++++++++--------------
> > > sound/core/pcm_native.c | 6 +++---
> > > 2 files changed, 20 insertions(+), 17 deletions(-)
> > >
> > > diff --git a/include/sound/pcm.h b/include/sound/pcm.h
> > > index 732121b934fd..c993350975a9 100644
> > > --- a/include/sound/pcm.h
> > > +++ b/include/sound/pcm.h
> > > @@ -109,20 +109,23 @@ struct snd_pcm_ops {
> > > #define SNDRV_PCM_RATE_5512 (1U<<0) /* 5512Hz */
> > > #define SNDRV_PCM_RATE_8000 (1U<<1) /* 8000Hz */
> > > #define SNDRV_PCM_RATE_11025 (1U<<2) /* 11025Hz */
> > > -#define SNDRV_PCM_RATE_16000 (1U<<3) /* 16000Hz */
> > > -#define SNDRV_PCM_RATE_22050 (1U<<4) /* 22050Hz */
> > > -#define SNDRV_PCM_RATE_32000 (1U<<5) /* 32000Hz */
> > > -#define SNDRV_PCM_RATE_44100 (1U<<6) /* 44100Hz */
> > > -#define SNDRV_PCM_RATE_48000 (1U<<7) /* 48000Hz */
> > > -#define SNDRV_PCM_RATE_64000 (1U<<8) /* 64000Hz */
> > > -#define SNDRV_PCM_RATE_88200 (1U<<9) /* 88200Hz */
> > > -#define SNDRV_PCM_RATE_96000 (1U<<10) /* 96000Hz */
> > > -#define SNDRV_PCM_RATE_176400 (1U<<11) /* 176400Hz */
> > > -#define SNDRV_PCM_RATE_192000 (1U<<12) /* 192000Hz */
> > > -#define SNDRV_PCM_RATE_352800 (1U<<13) /* 352800Hz */
> > > -#define SNDRV_PCM_RATE_384000 (1U<<14) /* 384000Hz */
> > > -#define SNDRV_PCM_RATE_705600 (1U<<15) /* 705600Hz */
> > > -#define SNDRV_PCM_RATE_768000 (1U<<16) /* 768000Hz */
> > > +#define SNDRV_PCM_RATE_12000 (1U<<3) /* 12000Hz */
> > > +#define SNDRV_PCM_RATE_16000 (1U<<4) /* 16000Hz */
> > > +#define SNDRV_PCM_RATE_22050 (1U<<5) /* 22050Hz */
> > > +#define SNDRV_PCM_RATE_24000 (1U<<6) /* 24000Hz */
> > > +#define SNDRV_PCM_RATE_32000 (1U<<7) /* 32000Hz */
> > > +#define SNDRV_PCM_RATE_44100 (1U<<8) /* 44100Hz */
> > > +#define SNDRV_PCM_RATE_48000 (1U<<9) /* 48000Hz */
> > > +#define SNDRV_PCM_RATE_64000 (1U<<10) /* 64000Hz */
> > > +#define SNDRV_PCM_RATE_88200 (1U<<11) /* 88200Hz */
> > > +#define SNDRV_PCM_RATE_96000 (1U<<12) /* 96000Hz */
> > > +#define SNDRV_PCM_RATE_128000 (1U<<13) /* 128000Hz */
> > > +#define SNDRV_PCM_RATE_176400 (1U<<14) /* 176400Hz */
> > > +#define SNDRV_PCM_RATE_192000 (1U<<15) /* 192000Hz */
> > > +#define SNDRV_PCM_RATE_352800 (1U<<16) /* 352800Hz */
> > > +#define SNDRV_PCM_RATE_384000 (1U<<17) /* 384000Hz */
> > > +#define SNDRV_PCM_RATE_705600 (1U<<18) /* 705600Hz */
> > > +#define SNDRV_PCM_RATE_768000 (1U<<19) /* 768000Hz */
> > >
> > > #define SNDRV_PCM_RATE_CONTINUOUS (1U<<30) /* continuous range */
> > > #define SNDRV_PCM_RATE_KNOT (1U<<31) /* supports more non-continuous rates */
> > > diff --git a/sound/core/pcm_native.c b/sound/core/pcm_native.c
> > > index 44381514f695..7461a727615c 100644
> > > --- a/sound/core/pcm_native.c
> > > +++ b/sound/core/pcm_native.c
> > > @@ -2418,13 +2418,13 @@ static int snd_pcm_hw_rule_sample_bits(struct snd_pcm_hw_params *params,
> > > return snd_interval_refine(hw_param_interval(params, rule->var), &t);
> > > }
> > >
> > > -#if SNDRV_PCM_RATE_5512 != 1 << 0 || SNDRV_PCM_RATE_192000 != 1 << 12
> > > +#if SNDRV_PCM_RATE_5512 != 1 << 0 || SNDRV_PCM_RATE_768000 != 1 << 19
> > > #error "Change this table"
> > > #endif
> > >
> > > static const unsigned int rates[] = {
> > > - 5512, 8000, 11025, 16000, 22050, 32000, 44100,
> > > - 48000, 64000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000
> > > + 5512, 8000, 11025, 12000, 16000, 22050, 24000, 32000, 44100, 48000, 64000,
> > > + 88200, 96000, 128000, 176400, 192000, 352800, 384000, 705600, 768000,
> > > };
> > >
> > > const struct snd_pcm_hw_constraint_list snd_pcm_known_rates = {
> >
> > Wondering if this is backwards compatible with the alsa-lib definitions,
> > specifically the topology parts which did unfortunately have a list of
> > rates that will map to a different index now:
> >
> >
> > typedef enum _snd_pcm_rates {
> > SND_PCM_RATE_UNKNOWN = -1,
> > SND_PCM_RATE_5512 = 0,
> > SND_PCM_RATE_8000,
> > SND_PCM_RATE_11025,
> > SND_PCM_RATE_16000,
> > SND_PCM_RATE_22050,
> > SND_PCM_RATE_32000,
> > SND_PCM_RATE_44100,
> > SND_PCM_RATE_48000,
> > SND_PCM_RATE_64000,
> > SND_PCM_RATE_88200,
> > SND_PCM_RATE_96000,
> > SND_PCM_RATE_176400,
> > SND_PCM_RATE_192000,
> > SND_PCM_RATE_CONTINUOUS = 30,
> > SND_PCM_RATE_KNOT = 31,
> > SND_PCM_RATE_LAST = SND_PCM_RATE_KNOT,
> > } snd_pcm_rates_t;
>
> As far as I understand correctly, those rate bits used for topology
> are independent from the bits used for PCM core, although it used to
> be the same. Maybe better to rename (such as SND_TPLG_RATE_*) so that
> it's clearer only for topology stuff.
>
> But it'd be better if anyone can double-check.

... and I double-check by myself and proved I was wrong :-<

In soc-topology.c, set_stream_info() takes the
snd_soc_pcm_stream.rates bits as is from the given topology data,
so the changes of the bits can break this.

The topology takes both rates and formats bits. The formats are a
part of uapi, but the rates aren't. We should move those into uapi,
if any...


Takashi