Re: [PATCH net-next V2 1/5] net: lan743x: Add SFP support check flag

From: Andrew Lunn
Date: Thu Sep 12 2024 - 10:52:56 EST


On Thu, Sep 12, 2024 at 11:59:04AM +0530, Raju Lakkaraju wrote:
> Hi Andrew,
>
> Thank you for review the patches.
>
> The 09/11/2024 19:06, Andrew Lunn wrote:
> > EXTERNAL EMAIL: Do not click links or open attachments unless you know the content is safe
> >
> > > + if (adapter->is_pci11x1x && !adapter->is_sgmii_en &&
> > > + adapter->is_sfp_support_en) {
> > > + netif_err(adapter, drv, adapter->netdev,
> > > + "Invalid eeprom cfg: sfp enabled with sgmii disabled");
> > > + return -EINVAL;
> >
> > is_sgmii_en actually means PCS? An SFP might need 1000BaseX or SGMII,
>
> No, not really.
> The PCI11010/PCI1414 chip can support either an RGMII interface or
> an SGMII/1000Base-X/2500Base-X interface.

A generic name for SGMII/1000Base-X/2500Base-X would be PCS, or maybe
SERDES. To me, is_sgmii_en means SGMII is enabled, but in fact it
actually means SGMII/1000Base-X/2500Base-X is enabled. I just think
this is badly named. It would be more understandable if it was
is_pcs_en.

> According to the datasheet,
> the "Strap Register (STRAP)" bit 6 is described as "SGMII_EN_STRAP"
> Therefore, the flag is named "is_sgmii_en".

Just because the datasheet uses a bad name does not mean the driver
has to also use it.

Andrew