On Tue, Sep 03, 2024 at 03:07:47PM +0000, John Garry wrote:
+ } else if (t->features & BLK_FEAT_ATOMIC_WRITES) {
+ t->atomic_write_hw_max = min_not_zero(t->atomic_write_hw_max,
+ b->atomic_write_hw_max);
+ t->atomic_write_boundary_sectors =
+ min_not_zero(t->atomic_write_boundary_sectors,
+ b->atomic_write_boundary_sectors);
+ t->atomic_write_hw_unit_min = max(t->atomic_write_hw_unit_min,
+ b->atomic_write_hw_unit_min);
+ t->atomic_write_hw_unit_max =
+ min_not_zero(t->atomic_write_hw_unit_max,
+ b->atomic_write_hw_unit_max);
Maybe split this into a helper to make the code more readable?
Otherwise this looks good to me.