Re: [PATCH] firmware: mtk-adsp-ipc: Switch to using dev_err_probe()

From: Uwe Kleine-König
Date: Thu Sep 19 2024 - 09:26:34 EST


Hello

On Thu, Sep 19, 2024 at 02:02:08PM +0200, AngeloGioacchino Del Regno wrote:
> There is an error path that checks whether the return value is
> -EPROBE_DEFER to decide whether to print the error message: that
> is exactly open-coding dev_err_probe(), so, switch to that.
>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@xxxxxxxxxxxxx>
> ---
> drivers/firmware/mtk-adsp-ipc.c | 7 +++----
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/firmware/mtk-adsp-ipc.c b/drivers/firmware/mtk-adsp-ipc.c
> index a762302978de..fdb083f42ebf 100644
> --- a/drivers/firmware/mtk-adsp-ipc.c
> +++ b/drivers/firmware/mtk-adsp-ipc.c
> @@ -95,10 +95,9 @@ static int mtk_adsp_ipc_probe(struct platform_device *pdev)
> adsp_chan->idx = i;
> adsp_chan->ch = mbox_request_channel_byname(cl, adsp_mbox_ch_names[i]);
> if (IS_ERR(adsp_chan->ch)) {
> - ret = PTR_ERR(adsp_chan->ch);
> - if (ret != -EPROBE_DEFER)
> - dev_err(dev, "Failed to request mbox chan %s ret %d\n",
> - adsp_mbox_ch_names[i], ret);
> + ret = dev_err_probe(dev, PTR_ERR(adsp_chan->ch),
> + "Failed to request mbox channel %s\n",
> + adsp_mbox_ch_names[i]);
>

Looks good to me:

Acked-by: Uwe Kleine-König <u.kleine-koenig@xxxxxxxxxxxx>

Best regards
Uwe

Attachment: signature.asc
Description: PGP signature