Re: [PATCH v1 03/11] perf build: Rename test-dwarf to test-libdw
From: Ian Rogers
Date: Thu Sep 26 2024 - 11:38:34 EST
On Wed, Sep 25, 2024 at 5:28 PM Namhyung Kim <namhyung@xxxxxxxxxx> wrote:
>
> On Tue, Sep 24, 2024 at 09:04:10AM -0700, Ian Rogers wrote:
> > Be more intention revealing that the dwarf test is actually testing
> > for libdw support.
> >
> > Signed-off-by: Ian Rogers <irogers@xxxxxxxxxx>
> > ---
> > tools/build/Makefile.feature | 6 +++---
> > tools/build/feature/Makefile | 16 ++++++++--------
> > tools/build/feature/test-all.c | 6 +++---
> > .../build/feature/{test-dwarf.c => test-libdw.c} | 0
> > tools/perf/Makefile.config | 6 +++---
> > 5 files changed, 17 insertions(+), 17 deletions(-)
> > rename tools/build/feature/{test-dwarf.c => test-libdw.c} (100%)
> >
> > diff --git a/tools/build/Makefile.feature b/tools/build/Makefile.feature
> > index ffd117135094..6025810cc346 100644
> > --- a/tools/build/Makefile.feature
> > +++ b/tools/build/Makefile.feature
> > @@ -30,7 +30,7 @@ endef
> > #
> > FEATURE_TESTS_BASIC := \
> > backtrace \
> > - dwarf \
> > + libdw \
> > dwarf_getlocations \
> > dwarf_getcfi \
> > eventfd \
> > @@ -120,7 +120,7 @@ ifeq ($(FEATURE_TESTS),all)
> > endif
> >
> > FEATURE_DISPLAY ?= \
> > - dwarf \
> > + libdw \
> > dwarf_getlocations \
> > glibc \
> > libbfd \
> > @@ -233,7 +233,7 @@ endef
> >
> > #
> > # generates feature value assignment for name, like:
> > -# $(call feature_assign,dwarf) == feature-dwarf=1
> > +# $(call feature_assign,libdw) == feature-libdw=1
> > #
> > feature_assign = feature-$(1)=$(feature-$(1))
> >
> > diff --git a/tools/build/feature/Makefile b/tools/build/feature/Makefile
> > index 5938cf799dc6..bece326ac93b 100644
> > --- a/tools/build/feature/Makefile
> > +++ b/tools/build/feature/Makefile
> > @@ -5,7 +5,7 @@ FILES= \
> > test-all.bin \
> > test-backtrace.bin \
> > test-bionic.bin \
> > - test-dwarf.bin \
> > + test-libdw.bin \
> > test-dwarf_getlocations.bin \
> > test-dwarf_getcfi.bin \
> > test-eventfd.bin \
> > @@ -168,9 +168,9 @@ $(OUTPUT)test-libopencsd.bin:
> > $(BUILD) # -lopencsd_c_api -lopencsd provided by
> > # $(FEATURE_CHECK_LDFLAGS-libopencsd)
> >
> > -DWARFLIBS := -ldw
> > +DWLIBS := -ldw
> > ifeq ($(findstring -static,${LDFLAGS}),-static)
> > - DWARFLIBS += -lelf -lz -llzma -lbz2 -lzstd
> > + DWLIBS += -lelf -lz -llzma -lbz2 -lzstd
> >
> > LIBDW_VERSION := $(shell $(PKG_CONFIG) --modversion libdw)
> > LIBDW_VERSION_1 := $(word 1, $(subst ., ,$(LIBDW_VERSION)))
> > @@ -179,18 +179,18 @@ ifeq ($(findstring -static,${LDFLAGS}),-static)
> > # Elfutils merged libebl.a into libdw.a starting from version 0.177,
> > # Link libebl.a only if libdw is older than this version.
> > ifeq ($(shell test $(LIBDW_VERSION_2) -lt 177; echo $$?),0)
> > - DWARFLIBS += -lebl
> > + DWLIBS += -lebl
> > endif
> > endif
> >
> > -$(OUTPUT)test-dwarf.bin:
> > - $(BUILD) $(DWARFLIBS)
> > +$(OUTPUT)test-libdw.bin:
> > + $(BUILD) $(DWLIBS)
> >
> > $(OUTPUT)test-dwarf_getlocations.bin:
> > - $(BUILD) $(DWARFLIBS)
> > + $(BUILD) $(DWLIBS)
> >
> > $(OUTPUT)test-dwarf_getcfi.bin:
> > - $(BUILD) $(DWARFLIBS)
> > + $(BUILD) $(DWLIBS)
> >
> > $(OUTPUT)test-libelf-getphdrnum.bin:
> > $(BUILD) -lelf
> > diff --git a/tools/build/feature/test-all.c b/tools/build/feature/test-all.c
> > index 6f4bf386a3b5..d60e072b6eca 100644
> > --- a/tools/build/feature/test-all.c
> > +++ b/tools/build/feature/test-all.c
> > @@ -38,8 +38,8 @@
> > # include "test-glibc.c"
> > #undef main
> >
> > -#define main main_test_dwarf
> > -# include "test-dwarf.c"
> > +#define main main_test_libdw
> > +# include "test-libdw.c"
> > #undef main
> >
> > #define main main_test_dwarf_getlocations
> > @@ -187,7 +187,7 @@ int main(int argc, char *argv[])
> > main_test_get_current_dir_name();
> > main_test_gettid();
> > main_test_glibc();
> > - main_test_dwarf();
> > + main_test_libdw();
> > main_test_dwarf_getlocations();
> > main_test_eventfd();
> > main_test_libelf_getphdrnum();
> > diff --git a/tools/build/feature/test-dwarf.c b/tools/build/feature/test-libdw.c
> > similarity index 100%
> > rename from tools/build/feature/test-dwarf.c
> > rename to tools/build/feature/test-libdw.c
> > diff --git a/tools/perf/Makefile.config b/tools/perf/Makefile.config
> > index 182e14e39cd5..c8e157cc0c5e 100644
> > --- a/tools/perf/Makefile.config
> > +++ b/tools/perf/Makefile.config
> > @@ -159,8 +159,8 @@ ifeq ($(findstring -static,${LDFLAGS}),-static)
> > DWARFLIBS += -lebl
> > endif
> > endif
> > -FEATURE_CHECK_CFLAGS-dwarf := $(LIBDW_CFLAGS)
> > -FEATURE_CHECK_LDFLAGS-dwarf := $(LIBDW_LDFLAGS) $(DWARFLIBS)
> > +FEATURE_CHECK_CFLAGS-libdw := $(LIBDW_CFLAGS)
> > +FEATURE_CHECK_LDFLAGS-libdw := $(LIBDW_LDFLAGS) $(DWARFLIBS)
>
> s/DWARFLIBS/DWLIBS/ ?
The patch is changing the name of a feature test. It is possible to
change this Makefile.config variable in the same patch but I think
they are distinct things and the variable rename is follow up work.
Thanks,
Ian
>
> > FEATURE_CHECK_CFLAGS-libdw-dwarf-unwind := $(LIBDW_CFLAGS)
> > FEATURE_CHECK_LDFLAGS-libdw-dwarf-unwind := $(LIBDW_LDFLAGS) $(DWARFLIBS)
>
> Ditto.
>
> Thanks,
> Namhyung
>
>
> > FEATURE_CHECK_CFLAGS-dwarf_getlocations := $(LIBDW_CFLAGS)
> > @@ -470,7 +470,7 @@ else
> > $(warning No libdw DWARF unwind found, Please install elfutils-devel/libdw-dev >= 0.158 and/or set LIBDW_DIR)
> > endif
> > endif
> > - ifneq ($(feature-dwarf), 1)
> > + ifneq ($(feature-libdw), 1)
> > ifndef NO_LIBDW
> > $(warning No libdw.h found or old libdw.h found or elfutils is older than 0.138, disables dwarf support. Please install new elfutils-devel/libdw-dev)
> > NO_LIBDW := 1
> > --
> > 2.46.0.792.g87dc391469-goog
> >