Re: [RFC PATCH] compiler.h: Introduce ptr_eq() to preserve address dependency

From: Paul E. McKenney
Date: Sat Sep 28 2024 - 07:32:11 EST


On Fri, Sep 27, 2024 at 07:05:53PM -0400, Mathieu Desnoyers wrote:
> On 2024-09-27 22:33, Mathieu Desnoyers wrote:
> [...]
>
> > ---
> > include/linux/compiler.h | 62 ++++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 62 insertions(+)
> >
>
> I'm wondering if this really belongs in compiler.h, or if it's so
> RCU/HP specific that it should be implemented in rcupdate.h ?
>
> [... ]
> > +static __always_inline
> > +int ptr_eq(const volatile void *a, const volatile void *b)
>
> And perhaps rename this to rcu_ptr_eq() ?

For either location or name:

Acked-by: Paul E. McKenney <paulmck@xxxxxxxxxx>

There are non-RCU uses, but RCU is currently by far the most common.

Thanx, Paul

> Thanks,
>
> Mathieu
>
> > +{
> > + OPTIMIZER_HIDE_VAR(a);
> > + OPTIMIZER_HIDE_VAR(b);
> > + return a == b;
> > +}
> > +
>
>
>
> --
> Mathieu Desnoyers
> EfficiOS Inc.
> https://www.efficios.com
>