Re: [PATCH net-next v19 09/14] net: rename skb_copy_to_page_nocache() helper
From: Yunsheng Lin
Date: Mon Oct 07 2024 - 10:32:05 EST
On 10/7/2024 12:18 AM, Alexander Duyck wrote:
...
I could probably live with sk_copy_to_skb_data_nocache since we also
refer to the section after the page section with data_len. The basic
idea is we are wanting to define what the function does with the
function name rather than just report the arguments it is accepting.
Yes, looking more closely:
skb_add_data_nocache() does memcpy'ing to skb->data and update skb->len
only by calling skb_put(), and skb_copy_to_page_nocache() does
memcpy'ing to skb frag by updating both skb->len and skb->data_len
through the calling of skb_len_add().
Perhaps skb_add_frag_nocache() might seems a better name for now, and
the 'sk_' prefix might be done in the future if it does make sense.