[PATCH v4 0/2] vdso: Use only headers from the vdso/ namespace

From: Vincenzo Frascino
Date: Thu Oct 10 2024 - 09:52:16 EST


The recent implementation of getrandom in the generic vdso library,
includes headers from outside of the vdso/ namespace.

The purpose of this series is to refactor the code to make sure
that the library uses only the allowed namespace.

Signed-off-by: Vincenzo Frascino <vincenzo.frascino@xxxxxxx>

Changes:
--------
v4:
- Address review comments.
v3:
- Discard vdso/mman.h changes in favor of [1].
- Refactor vdso/page.h.
- Add a fix to drm/intel_gt.
v2:
- Added common PAGE_SIZE and PAGE_MASK definitions.
- Added opencoded macros where not defined.
- Dropped VDSO_PAGE_* redefinitions.

[1] https://lore.kernel.org/lkml/20240925210615.2572360-1-arnd@xxxxxxxxxx

Vincenzo Frascino (2):
drm: i915: Change fault type to unsigned long
vdso: Introduce vdso/page.h

arch/alpha/include/asm/page.h | 6 +-----
arch/arc/include/uapi/asm/page.h | 7 +++----
arch/arm/include/asm/page.h | 5 +----
arch/arm64/include/asm/page-def.h | 5 +----
arch/csky/include/asm/page.h | 8 ++------
arch/hexagon/include/asm/page.h | 4 +---
arch/loongarch/include/asm/page.h | 7 +------
arch/m68k/include/asm/page.h | 6 ++----
arch/microblaze/include/asm/page.h | 5 +----
arch/mips/include/asm/page.h | 7 +------
arch/nios2/include/asm/page.h | 7 +------
arch/openrisc/include/asm/page.h | 11 +----------
arch/parisc/include/asm/page.h | 4 +---
arch/powerpc/include/asm/page.h | 10 +---------
arch/riscv/include/asm/page.h | 4 +---
arch/s390/include/asm/page.h | 4 +---
arch/sh/include/asm/page.h | 6 ++----
arch/sparc/include/asm/page_32.h | 4 +---
arch/sparc/include/asm/page_64.h | 4 +---
arch/um/include/asm/page.h | 5 +----
arch/x86/include/asm/page_types.h | 5 +----
arch/xtensa/include/asm/page.h | 8 +-------
drivers/gpu/drm/i915/gt/intel_gt.c | 6 +++---
include/vdso/page.h | 30 ++++++++++++++++++++++++++++++
24 files changed, 60 insertions(+), 108 deletions(-)
create mode 100644 include/vdso/page.h

--
2.34.1