Re: [PATCH v4 5/13] LSM: Use lsm_prop in security_ipc_getsecid
From: Paul Moore
Date: Thu Oct 10 2024 - 23:09:14 EST
On Oct 9, 2024 Casey Schaufler <casey@xxxxxxxxxxxxxxxx> wrote:
>
> There may be more than one LSM that provides IPC data for auditing.
> Change security_ipc_getsecid() to fill in a lsm_prop structure instead
> of the u32 secid. Change the name to security_ipc_getlsmprop() to
> reflect the change.
>
> Signed-off-by: Casey Schaufler <casey@xxxxxxxxxxxxxxxx>
> Cc: audit@xxxxxxxxxxxxxxx
> Cc: linux-security-module@xxxxxxxxxxxxxxx
> Cc: selinux@xxxxxxxxxxxxxxx
> ---
> include/linux/lsm_hook_defs.h | 4 ++--
> include/linux/security.h | 22 +++++++++++++++++-----
> kernel/auditsc.c | 5 ++---
> security/security.c | 14 +++++++-------
> security/selinux/hooks.c | 9 ++++++---
> security/smack/smack_lsm.c | 16 +++++++++-------
> 6 files changed, 43 insertions(+), 27 deletions(-)
>
> diff --git a/include/linux/lsm_hook_defs.h b/include/linux/lsm_hook_defs.h
> index ed6ea0b1ec57..6ef2a345ea03 100644
> --- a/include/linux/lsm_hook_defs.h
> +++ b/include/linux/lsm_hook_defs.h
> @@ -256,8 +256,8 @@ LSM_HOOK(void, LSM_RET_VOID, task_to_inode, struct task_struct *p,
> struct inode *inode)
> LSM_HOOK(int, 0, userns_create, const struct cred *cred)
> LSM_HOOK(int, 0, ipc_permission, struct kern_ipc_perm *ipcp, short flag)
> -LSM_HOOK(void, LSM_RET_VOID, ipc_getsecid, struct kern_ipc_perm *ipcp,
> - u32 *secid)
> +LSM_HOOK(void, LSM_RET_VOID, ipc_getlsmprop, struct kern_ipc_perm *ipcp,
> + struct lsm_prop *prop)
> LSM_HOOK(int, 0, msg_msg_alloc_security, struct msg_msg *msg)
> LSM_HOOK(void, LSM_RET_VOID, msg_msg_free_security, struct msg_msg *msg)
> LSM_HOOK(int, 0, msg_queue_alloc_security, struct kern_ipc_perm *perm)
> diff --git a/include/linux/security.h b/include/linux/security.h
> index 5652baa4ca3c..15aef5f68e77 100644
> --- a/include/linux/security.h
> +++ b/include/linux/security.h
> @@ -289,6 +289,17 @@ static inline const char *kernel_load_data_id_str(enum kernel_load_data_id id)
> return kernel_load_data_str[id];
> }
>
> +/**
> + * lsmprop_init - initialize a lsm_prop structure
> + * @prop: Pointer to the data to initialize
> + *
> + * Set all secid for all modules to the specified value.
> + */
> +static inline void lsmprop_init(struct lsm_prop *prop)
> +{
> + memset(prop, 0, sizeof(*prop));
> +}
> +
> #ifdef CONFIG_SECURITY
>
> /**
> @@ -297,7 +308,7 @@ static inline const char *kernel_load_data_id_str(enum kernel_load_data_id id)
> *
> * Returns true if there is a value set, false otherwise
> */
> -static inline bool lsm_prop_is_set(struct lsm_prop *prop)
> +static inline bool lsmprop_is_set(struct lsm_prop *prop)
See my comment in patch 4/13 about naming it this way from the start.
--
paul-moore.com