Re: [RFC PATCH] drivers: hv: Convert open-coded timeouts to msecs_to_jiffies()

From: Easwar Hariharan
Date: Fri Oct 18 2024 - 18:50:04 EST


On 10/18/2024 12:54 AM, Praveen Kumar wrote:
> On 17-10-2024 04:07, Easwar Hariharan wrote:
>> We have several places where timeouts are open-coded as N (seconds) * HZ,
>> but best practice is to use msecs_to_jiffies(). Convert the timeouts to
>> make them HZ invariant.
>>> Signed-off-by: Easwar Hariharan <eahariha@xxxxxxxxxxxxxxxxxxx>
>> ---
>> drivers/hv/hv_balloon.c | 9 +++++----
>> drivers/hv/hv_kvp.c | 4 ++--
>> drivers/hv/hv_snapshot.c | 6 ++++--
>> drivers/hv/vmbus_drv.c | 2 +-
>> 4 files changed, 12 insertions(+), 9 deletions(-)
>>
>> diff --git a/drivers/hv/hv_balloon.c b/drivers/hv/hv_balloon.c
>> index c38dcdfcb914d..3017d41f12681 100644
>> --- a/drivers/hv/hv_balloon.c
>> +++ b/drivers/hv/hv_balloon.c
>> @@ -756,7 +756,7 @@ static void hv_mem_hot_add(unsigned long start, unsigned long size,
>> * adding succeeded, it is ok to proceed even if the memory was
>> * not onlined in time.
>> */
>> - wait_for_completion_timeout(&dm_device.ol_waitevent, 5 * HZ);
>> + wait_for_completion_timeout(&dm_device.ol_waitevent, msecs_to_jiffies(5 * 1000));
>
> Is it correct to convert HZ to 1000 ?
> Also, how are you testing these changes ?
>

It's a conversion of milliseconds to seconds, rather than HZ to 1000. :)
msecs_to_jiffies() handles the conversion to jiffies with HZ. As Naman
mentioned, this could be equivalently written as 5 * MSECS_PER_SEC, and
would probably be more readable. On testing, this is only
compile-tested, and that's part of the reason why it's an RFC, since I'm
not 100% sure every one of these timeouts is measured in seconds. Hoping
for folks more familiar with the code to take a look.

Thanks,
Easwar