On Thu, Oct 24, 2024 at 12:32 PM Lukasz Luba <lukasz.luba@xxxxxxx> wrote:
On 10/16/24 12:33, Rafael J. Wysocki wrote:
From: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
Since thermal_zone_set_trip_temp() is not located in the same file
nit: s/not/now
Thanks, will fix when applying the patch.
as thermal_trip_crossed(), it can invoke the latter directly without
using the thermal_zone_trip_down() wrapper that has no other users.
Update thermal_zone_set_trip_temp() accordingly and drop
thermal_zone_trip_down().
No functional impact.
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx>
---
drivers/thermal/thermal_core.c | 8 +-------
drivers/thermal/thermal_core.h | 2 --
2 files changed, 1 insertion(+), 9 deletions(-)
Index: linux-pm/drivers/thermal/thermal_core.c
===================================================================
--- linux-pm.orig/drivers/thermal/thermal_core.c
+++ linux-pm/drivers/thermal/thermal_core.c
@@ -565,7 +565,7 @@ void thermal_zone_set_trip_temp(struct t
* are needed to compensate for the lack of it going forward.
*/
if (tz->temperature >= td->threshold)
- thermal_zone_trip_down(tz, td);
+ thermal_trip_crossed(tz, td, thermal_get_tz_governor(tz), false);
minor thing:
won't that be too long line?
It is longer than 80 characters, but this is not a hard boundary - see
"2) Breaking long lines and strings" in
Documentation/process/coding-style.rst).
Well, you can argue about the "hide information" part, but IMV this
line just looks cleaner the way it is than when it would be broken in
any way.
IMHO we can add somewhere earlier:
struct thermal_governor *gov = thermal_get_tz_governor(tz);
and use it here
That would have been harder to follow than the current code IMO.