Re: [PATCH net-next] net: Use str_yes_no() and str_no_yes() helper functions
From: Willem de Bruijn
Date: Sat Oct 26 2024 - 10:55:02 EST
Thorsten Blum wrote:
> Remove hard-coded strings by using the str_yes_no() and str_no_yes()
> helper functions.
>
> Signed-off-by: Thorsten Blum <thorsten.blum@xxxxxxxxx>
> ---
> net/core/sock.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/net/core/sock.c b/net/core/sock.c
> index 039be95c40cf..132c8d2cda26 100644
> --- a/net/core/sock.c
> +++ b/net/core/sock.c
> @@ -4140,7 +4140,7 @@ static long sock_prot_memory_allocated(struct proto *proto)
> static const char *sock_prot_memory_pressure(struct proto *proto)
> {
> return proto->memory_pressure != NULL ?
> - proto_memory_pressure(proto) ? "yes" : "no" : "NI";
> + str_yes_no(proto_memory_pressure(proto)) : "NI";
> }
>
> static void proto_seq_printf(struct seq_file *seq, struct proto *proto)
> @@ -4154,7 +4154,7 @@ static void proto_seq_printf(struct seq_file *seq, struct proto *proto)
> sock_prot_memory_allocated(proto),
> sock_prot_memory_pressure(proto),
> proto->max_header,
> - proto->slab == NULL ? "no" : "yes",
> + str_no_yes(proto->slab == NULL),
Just one opinion, but to reiterate from a previous similar patch:
I find this less readable than the original open code variant.
include/linux/string_choices.h mentions three goals: elegance,
consistency and binary size. The third goal could be an argument for
this change perhaps.
proto->slab : "yes" : "no" would arguably be even easier than the
current form, and a conversion could similarly use str_yes_no.