Re: [PATCH RFC v4 02/15] spi: add basic support for SPI offloading
From: Mark Brown
Date: Wed Oct 30 2024 - 11:55:44 EST
On Wed, Oct 23, 2024 at 03:59:09PM -0500, David Lechner wrote:
> +struct spi_offload *devm_spi_offload_alloc(struct device *dev,
> + size_t num_offloads,
> + size_t priv_size)
> + privs = (void *)(offloads + num_offloads);
Casting to or from void * is generally suspicious.
> + void *priv = privs + i * priv_size;
Can we have some brackets here for clarity please?
Attachment:
signature.asc
Description: PGP signature