Re: [PATCH] kdb: Fix incorrect naming of history arrow keys in code

From: Nir Lichtman
Date: Thu Oct 31 2024 - 20:27:23 EST


On Thu, Oct 31, 2024 at 04:06:03PM -0700, Doug Anderson wrote:
> >
> > kdb doesn't react to ctrl p and n, and following the code flow with GDB
> > reveals that these values map to the up and down arrows.
>
> Really? kdb reacts to "ctrl-P" and "ctrl-N" for me. It also reacts to
> "ctrl-F" and "ctrl-B".
>

Interesting, how do you run kdb? I use the kgdboc=kbd kernel boot param.
I haven't checked with serial as the console since I work with the keyboard,
but if serial does go through this using ctrl+p/n then the code in the
current state is misleading since the keys change depending on the I/O method.

Evidence in the code for usage of arrow keys in the case of keyboard can
be seen by examining kdb_read in kernel/debug/kdb/kdb_io.c, in the /* Down */
and /* Up */ cases the values 14 and 16 can be seen.

Do you suggest to keep as is or to work on a patch with a more generic name that
would fit both?

Thanks,
Nir

>
> -Doug