Re: [PATCH v5 27/28] media: iris: enable video driver probe of SM8250 SoC
From: Jianhua Lu
Date: Tue Nov 05 2024 - 09:34:19 EST
On Tue, Nov 05, 2024 at 10:22:17PM +0800, Jianhua Lu wrote:
> On Tue, Nov 05, 2024 at 12:25:47PM +0530, Dikshita Agarwal wrote:
> > Initialize the platform data and enable video driver probe of SM8250
> > SoC. Add a kernel param to select between venus and iris drivers for
> > platforms supported by both drivers, for ex: SM8250.
> >
> > Signed-off-by: Dikshita Agarwal <quic_dikshita@xxxxxxxxxxx>
> > ---
> [..]
> > --- a/drivers/media/platform/qcom/iris/iris_platform_common.h
> > +++ b/drivers/media/platform/qcom/iris/iris_platform_common.h
> [..]
> > +struct iris_platform_data sm8250_data = {
>
> You should qualitfy it with static too.
Sorry, I overlooked some code above, please ignore this comment.
>
> > + .get_instance = iris_hfi_gen1_get_instance,
> > + .init_hfi_command_ops = &iris_hfi_gen1_command_ops_init,
> > + .init_hfi_response_ops = iris_hfi_gen1_response_ops_init,
> [..]
> > diff --git a/drivers/media/platform/qcom/iris/iris_probe.c b/drivers/media/platform/qcom/iris/iris_probe.c
> > index 7b7378b7abb3..4cbaa889322e 100644
> > --- a/drivers/media/platform/qcom/iris/iris_probe.c
> > +++ b/drivers/media/platform/qcom/iris/iris_probe.c
> [..]
> > +static bool video_drv_should_bind(struct device *dev, bool iris_driver)
>
> Variable name iris_driver isn't good enough, rename it to
> is_iris_driver please.
>
> > +{
> > + if (of_device_compatible_match(dev->of_node, iris_only_platforms))
> > + return iris_driver;
> > +
> > + /* If it is not in the migration list, use venus */
> > + if (!of_device_compatible_match(dev->of_node, venus_to_iris_migration))
> > + return !iris_driver;
> > +
> > + return prefer_venus ? !iris_driver : iris_driver;
> > +}
> > +
> > --
> > 2.34.1
> >