Re: [PATCH v3 2/2] fs: add the ability for statmount() to report the mnt_devname

From: Miklos Szeredi
Date: Mon Nov 11 2024 - 09:31:23 EST


On Thu, 7 Nov 2024 at 22:00, Jeff Layton <jlayton@xxxxxxxxxx> wrote:

> diff --git a/include/uapi/linux/mount.h b/include/uapi/linux/mount.h
> index 2e939dddf9cbabe574dafdb6cff9ad4cf9298a74..3de1b0231b639fb8ed739d65b5b5406021f74196 100644
> --- a/include/uapi/linux/mount.h
> +++ b/include/uapi/linux/mount.h
> @@ -174,7 +174,7 @@ struct statmount {
> __u32 mnt_point; /* [str] Mountpoint relative to current root */
> __u64 mnt_ns_id; /* ID of the mount namespace */
> __u32 fs_subtype; /* [str] Subtype of fs_type (if any) */
> - __u32 __spare1[1];
> + __u32 mnt_devname; /* [str] Device string for the mount */

One more point: this is called source in both the old mount(2) API
and in new the fsconfig(2) API, where it's handled just like a plain
option (i.e. "-osource=/dev/foo").

Also this is a sb property, not a mount property, so the naming is confusing.

So I'd call this "sb_source" for consistency.

Thanks,
Miklos