[PATCH v4 0/3] fs: allow statmount to fetch the fs_subtype and sb_source

From: Jeff Layton
Date: Mon Nov 11 2024 - 10:10:29 EST


Meta has some internal logging that scrapes /proc/self/mountinfo today.
I'd like to convert it to use listmount()/statmount(), so we can do a
better job of monitoring with containers. We're missing some fields
though. This patchset adds them.

Signed-off-by: Jeff Layton <jlayton@xxxxxxxxxx>
---
Changes in v4:
- Rename mnt_devname to sb_source
- Break statmount_string() behavior changes out into separate patch
- Link to v3: https://lore.kernel.org/r/20241107-statmount-v3-0-da5b9744c121@xxxxxxxxxx

Changes in v3:
- Unescape the result of ->show_devname
- Move handling of nothing being emitted out of the switch statement
- Link to v2: https://lore.kernel.org/r/20241106-statmount-v2-0-93ba2aad38d1@xxxxxxxxxx

Changes in v2:
- make statmount_fs_subtype
- return fast if no subtype is emitted
- new patch to allow statmount() to return devicename
- Link to v1: https://lore.kernel.org/r/20241106-statmount-v1-1-b93bafd97621@xxxxxxxxxx

---
Jeff Layton (3):
fs: don't let statmount return empty strings
fs: add the ability for statmount() to report the fs_subtype
fs: add the ability for statmount() to report the sb_source

fs/namespace.c | 68 ++++++++++++++++++++++++++++++++++++++++++----
include/uapi/linux/mount.h | 6 +++-
2 files changed, 67 insertions(+), 7 deletions(-)
---
base-commit: 26213e1a6caa5a7f508b919059b0122b451f4dfe
change-id: 20241106-statmount-3f91a7ed75fa

Best regards,
--
Jeff Layton <jlayton@xxxxxxxxxx>