[PATCH 00/16] SRCU for v6.13
From: Frederic Weisbecker
Date: Tue Nov 12 2024 - 09:52:22 EST
Hello,
Please find below the SRCU patches targeted for the upcoming
merge window.
Paul E. McKenney (15):
srcu: Rename srcu_might_be_idle() to srcu_should_expedite()
srcu: Introduce srcu_gp_is_expedited() helper function
srcu: Renaming in preparation for additional reader flavor
srcu: Bit manipulation changes for additional reader flavor
srcu: Standardize srcu_data pointers to "sdp" and similar
srcu: Improve srcu_read_lock{,_nmisafe}() comments
srcu: Create CPP macros for normal and NMI-safe SRCU readers
srcu: Add srcu_read_lock_lite() and srcu_read_unlock_lite()
srcu: Allow inlining of __srcu_read_{,un}lock_lite()
rcutorture: Expand RCUTORTURE_RDR_MASK_[12] to eight bits
rcutorture: Add reader_flavor parameter for SRCU readers
rcutorture: Add srcu_read_lock_lite() support to
rcutorture.reader_flavor
rcutorture: Add light-weight SRCU scenario
refscale: Add srcu_read_lock_lite() support using "srcu-lite"
srcu: Improve srcu_read_lock_lite() kernel-doc comment
Zhen Lei (1):
srcu: Replace WARN_ON_ONCE() with BUILD_BUG_ON() if possible
.../admin-guide/kernel-parameters.txt | 8 ++
include/linux/srcu.h | 90 ++++++++++---
include/linux/srcutree.h | 46 ++++++-
kernel/rcu/rcutorture.c | 65 +++++----
kernel/rcu/refscale.c | 37 +++++-
kernel/rcu/srcutree.c | 123 +++++++++++-------
.../selftests/rcutorture/configs/rcu/CFLIST | 1 +
.../selftests/rcutorture/configs/rcu/SRCU-L | 10 ++
.../rcutorture/configs/rcu/SRCU-L.boot | 3 +
.../rcutorture/configs/rcu/SRCU-N.boot | 1 +
.../selftests/rcutorture/configs/rcu/TREE10 | 2 +-
11 files changed, 295 insertions(+), 91 deletions(-)
create mode 100644 tools/testing/selftests/rcutorture/configs/rcu/SRCU-L
create mode 100644 tools/testing/selftests/rcutorture/configs/rcu/SRCU-L.boot
Thanks.
--
2.46.0