Re: [PATCH v7 00/10] Add RAPL core energy counter support for AMD CPUs

From: Peter Zijlstra
Date: Tue Nov 19 2024 - 07:23:35 EST


On Fri, Nov 15, 2024 at 06:07:56AM +0000, Dhananjay Ugwekar wrote:
>
> Dhananjay Ugwekar (9):
> perf/x86/rapl: Remove the unused get_rapl_pmu_cpumask() function
> perf/x86/rapl: Remove the cpu_to_rapl_pmu() function
> perf/x86/rapl: Rename rapl_pmu variables
> perf/x86/rapl: Make rapl_model struct global
> perf/x86/rapl: Add arguments to the init and cleanup functions
> perf/x86/rapl: Modify the generic variable names to *_pkg*
> perf/x86/rapl: Remove the global variable rapl_msrs
> perf/x86/rapl: Move the cntr_mask to rapl_pmus struct
> perf/x86/rapl: Add core energy counter support for AMD CPUs
>
> K Prateek Nayak (1):
> x86/topology: Introduce topology_logical_core_id()
>
> Documentation/arch/x86/topology.rst | 4 +
> arch/x86/events/rapl.c | 414 ++++++++++++++++----------
> arch/x86/include/asm/processor.h | 1 +
> arch/x86/include/asm/topology.h | 1 +
> arch/x86/kernel/cpu/debugfs.c | 1 +
> arch/x86/kernel/cpu/topology_common.c | 1 +
> 6 files changed, 272 insertions(+), 150 deletions(-)

Thanks, I'll stick them in a tree post -rc1.